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SECTION 1 - VAOT InRoads FUNDAMENTALS MANUAL 
 
1. INTRODUCTION  
 
The primary functions of the VAOT InRoads Fundamentals Manual are to: 
 

1. Provide requirements and guidance on Bentley InRoads applications methods 
and standards used by VAOT when using the InRoads applications. 

 
2. Assure uniformity of practice for projects designed by or for the Agency. 

 
This manual does not eliminate the need for other references or training.  Instructions from 
CADD support, books, publications and other related material may need to be referred to for 
further details, or clarification.  Portions of the material in this manual may be specifically 
superseded by subsequent Official Issuances of the Agency (e.g., Engineering Instructions). 
 
Variations from this manual will be necessary for special or unusual conditions, or between the 
issuances of new or revised source documents and any corresponding updates of the VAOT 
InRoads Fundamentals Manual (reference).  Consequently, instructions in this document are 
not intended to preclude the exercise of individual initiative and judgment in reaction to project 
specific conditions or application of current state of the art practices.  Rather, such initiative and 
judgment is encouraged when it is appropriate and there is a rational basis for deviation.  
However, it is equally important that there be consistency in the application of this manual. The 
objective is uniformity of process and presentation. 
 
1.1. DISTRIBUTION 
 
This manual, in its entirety, may be freely copied and distributed for the purpose of 
providing a consistent guide to InRoads Design requirements of the Vermont Agency of 
Transportation.  This manual, Standard CADD files and other support files can be 
downloaded from the VAOT CADD website at the following address. 
 

http://www.aot.state.vt.us/caddhelp
 

http://www.aot.state.vt.us/caddhelp
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1.2. REVISIONS AND UPDATES 
 
The office of VAOT CADD support IT section, with input from the VAOT CADD 
Technical Committee, CADD users and the consultant and construction community, will 
develop and maintain standards and configuration files for the Agency’s Computer 
Aided Design related activities.   
 
If you have comments or suggestions please email: AOTCaddMaster@state.vt.us  
 
The Vermont Agency of Transportation strives to stay current with state of the art trends 
in AEC technical advancements.  Impacts on project delivery schedules and the 
resources necessary to provide future support for new features must be considered 
prior to any change.  Updating this manual is intended to be an ongoing process.  
Revisions will be issued periodically and posted at the CADD website address shown in 
Section 1.1 Distribution.   
 
Revisions to this manual will be documented in Appendix Z - Amendments.  
 
1.3. TRADEMARKS 
 
“MicroStation” and “InRoads”, are registered trademarks of Bentley Systems, 
Incorporated.  Other trade names computer protocols, and file formats mentioned in this 
manual are the trademarks of their respective owners.  In no event will the appearance 
of any graphic, description of a graphic, picture, screen display, or any other method of 
conveying meaning, be considered to impair the rights of the respective owners.

mailto:AOTCaddMaster@state.vt.us
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SECTION 2 – INTRODUCTION TO Bentley InRoads 
 
2. INTRODUCTION 

InRoads includes the features your road and site design work requires. It offers advanced DTM 
capability, associative alignments with spirals, user-defined template typical sections -- including 
superelevation and independent slope and ditch control. Plans, profiles, cross sections, contour 
mapping and design data reports can be extracted from a design model. 

MicroStation is the platform application for which InRoads runs in combination with.  
MicroStation is used to view, display and present InRoads design data with a variety of options. 

2.1. STARTING THE APPLICATION 

There are several methods for starting InRoads.  The official method for starting InRoads is to 
use the Windows Start menu > All Programs > Bentley > InRoads Group XM > InRoads.  This 
will start MicroStation and load InRoads.  InRoads executable files can be copied to your desk 
top as shortcut icons with a < right click > drag to your desk top > release > select copy here.  
Other methods for starting InRoads use the MDL application startups.  For InRoads 8.9 the MDL 
startup is in the “bin” folder as shown below. 

“C:\Program Files\Bentley\InRoads Group V8.9\bin\CivUstXM.ma” 

You can use the MDL application browse option or the MicroStation key-in option by keying in 
the path shown above including the quotes.  There are also startup menu options under the 
MicroStation VAOT menu that will start InRoads.   

InRoads, records your application preferences in the windows registry.  All customization of 
tools and preferences are stored in your personal windows profile.  Other users of your 
computer will not have the same settings; if you change computers your InRoads 
customizations will not follow you.  If you get a new service pack for InRoads your settings 
should remain intact, if you get a new release your settings may not remain. 

2.2. InRoads INTERFACE AND EXPLORER WINDOWS 

When you load InRoads you will get the InRoads Explorer which contains a main menu bar and 
two windows for viewing and manipulating active data files and their contents.  All InRoads 
command can be located from the main menu bar.  Tool bars can be activated for quick access 
to the different commands and dialogs.  Right click on the gray space to the right of the InRoads 
main menu help, you will get a shortcut to the LOCKS tool bar (you will need to activate this tool 
by clicking on locks) and to the Customize dialog where all tool bars are listed.   The lock tools 
are shown below, with a description.  In bold are common setting, on or off etc. 

        

Feature 
Highlight 
Lock ON 

Style 
Lock 
OFF 

Pencil or 
Pen 

Mode 

Delete 
Ink Lock 

OFF 

Graphics 
or 

Features 

Point 
Element 
No Snap 

Station 
Lock ON 

Report 
Lock 
OFF 
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2.2.1. Explore Window Functions 

The left window (Workspace Bar) contains a listing of active data; in the image above the 
window is displaying Geometry Project Data.  The red square near the + symbol indicates the 
active Geometry Project.  A < right click > on geometry listed in the Geometry window will active 
a shortcut dialog with options to Save, Copy, set Active etc.   Tabs at the bottom of the window 
allow you to toggle to the different data files types loaded i.e. Surface Data, Template Library 
File etc. 
 

 
 

The right window is displaying information about data contained in the geometry project,  In this 
case we have 6 horizontal alignments listed and the Cogo Buffer.  Again the red square 
indicates the active horizontal alignment.  The importance of active data will become more 
apparent as we move through this manual.  Each Horizontal Alignment has a Name and 
Description; the description will be very useful as the project grows.  All Horizontal Alignments 
should have GOOD descriptions. 

2.3. ONLINE APPLICATION HELP 

This manual is not intended to be a sole source of information to the InRoads user.  InRoads, 
has extensive online help available through the main menu Help.  Additionally when you are 
using the different InRoads dialog boxes, each box has a Help button.  These buttons link you 
directly to information specific to the work being preformed.  It is generally expected that new or 
even seasoned InRoads users will need to reference the online help regularly.  There is vast 
number of tools available and most have many options.  The best solution to a problem usually 
requires testing and multiple options.   Practice and experience using InRoads is the key to 
being proficient at using InRoads.   

VAOT CADD support has setup InRoads preferences and standardized VAOT InRoads 
practices in an effort make using InRoads as productive as possible.   

InRoads Help Contents contains a media library with video presentations and example of 
standard workflows.  

2.4. THE T: DRIVE & ITS STRUCTURE 

An overview of the T: Drive and an explanation of what this network drive is used for can be 
found in the VAOT CADD Standards and Procedure Manual.  In an effort to reduce duplication 
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of effort this document will concentrate on the portions of the T: Drive that pertains directly to 
InRoads.  VAOT standardized InRoads files are located in the path structure show below.  An 
explanation and details on the use to these files will follow through this manual.  See Resource 
File Location Table 2a. 

Table: 2a 

T:\CADD\Workspace\Projects\English\InRoads (OR) T:\CADD\Workspace\Projects\Metric\InRoads

Folder Name Content Description 

Prefs Preference Files  .xin  (replaces the .ini) 

SnSdata Storm Water Data Files  .idf  .dat 

super Super Elevation Tables - AASHTO 2001 & AASHTO 2004) 

template Typical Section Template Library Files  .itl (replaces the .tml) 

XMLreports VAOT Customized XML Report Style Sheets 
* The T: dirve or \\AOTCADD\CADDSTD share is the VAOT in-house storage location for resource files.  For off network configurations the 
locations are similar, substitute the T:\CADD\Workspace with C:\Program Files\Bentley\Workspace.  All VAOT CADD standards resource 
files can be downloaded at the VAOT CADD Help web sit. 

 

2.5. BASIC InRoads FILE TYPES DEFINED 

The files listed and described below are the basic files that all InRoads user will need to be very 
familiar with.  Every VAOT project designed using InRoads will use the file listed below.   
Learning what each of these files is used for and what data is contained in them will greatly 
increase your odds of being a successful InRoads user. 

2.5.1. Surface File = (.dtm): 
Digital Terrain Models: Existing ground and design terrain surface models are stored in 
these files.  A DTM is composed of point data, triangulation of point data, and a 
perimeter.  Point data can be stored in several features types, Random, Breakline, 
Contour, Interior Boundary, Exterior Boundary, and Inferred.  Point data is not required 
to be part of the triangulation, some points are tagged Do Not Triangulate. 

2.5.2. Geometry File = (.alg): 
This file consists of all the horizontal and vertical design data for the project.  Roadway 
horizontal geometry consists mainly of Tangent Lines and PI points, Curve definitions, 
Stationing, and Events.  Roadway vertical geometry consists mainly of linear elements 
defining grade; parabolic curves defining sag and crest vertical curves. 

2.5.3. InRoads Template Library = (.itl): 
This file is the collection of templates (or typical sections) used to define the proposed 
roadway.  Templates define the cross section construction of the roadway transverse to 
the roadway horizontal geometry. 

2.5.4. InRoads Roadway Designer = (.ird): 
This file contains information defining what templates are used at specified stations, and 
additional parameters, including super elevation controls to model a corridor.  The 
combination of cross section templates, Horizontal and Vertical geometry are combined 
go generate a 3 dimensional Digital Terrain Models with points defined by the template 
drops as they follow the geometry.  Super elevation control lines are saved in this file. 

http://www.aot.state.vt.us/Caddhelp/default.htm
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2.5.5. General Preference File = (.xin): 
This file contains all general parameters for InRoads including the alignment and 
geometry point parameters.  This is the main source of standardization where all 
InRoads design and graphical output are configured to meet VAOT standards. 

2.5.6. Inroads Project File = (.rwk):  
This file contains directory and file information for loading and saving InRoads data files.  
Opening a project file opens all files specified (listed) in the Project File. 

2.6. OTHER InRoads FILE TYPES DEFINED 
 
2.6.1. Survey Data = (fwd): 

InRoads Survey Fieldbook data file.  This file is created by importing survey data from a field 
data collector.  InRoads, converts and combines survey data and saves all edits to the survey 
data in the Fieldbook data file. 

2.6.2. Storm Drainage Database = (sdb): 

InRoads Storm & Sanitary database file where project storm water design information is stored.  
This includes type and locations of Drainage Inlets, Pipes, Culverts and the defined drainage 
areas. 

2.6.3. Drainage Structures = (dat): 

This file contains VAOT-defined materials, roughness coefficients, sizes and thicknesses for 
pipes, culverts, channels, manholes, and inlets. 

2.6.4. Interactive Coordinate Geometry Subsystem = (ICS): 

This file format is used to import coordinate geometry data into the InRoads. Information for this 
file format is provided in the Cogo Classic Commands. 

2.6.5. ASCII file format = (txt): 

InRoads both imports and exports a variety of ASCII text file formats.  This includes coma 
separated CSV files; pipe delineated files tab delineated and much more.  Text import and 
export is customizable to the needs. 
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SECTION 3 – SETTING UP & LOADING DATA 

 
3. INTRODUCTION 

Setting up an organized working environment and having standardized file management greatly 
increases productivity and reduces probability for errors.  Having the correct files loaded is 
essential to a proper design.  InRoads users must master file management for all InRoads 
design and data files.  InRoads provides methods for working with the correct preferences and 
data files via setting up project defaults and creating a project file for each project. 

Setting up the project defaults and creating a project file helps you quickly load all files needed 
to get the job done.  Additionally, the project file helps coworkers load and analyze current 
design data.  Keeping the project file current is an important part of project file management. 

3.1. CREATE PROJECT WORKING DESIGN FILE (dgn) 

The InRoads user needs to have a MicroStation Design file (dgn) to work on InRoads design 
data.  This is known as the InRoads work (wrk) file where all InRoads work is performed.  
Create this file by either saving the PROJ#sv.dgn as PROJ#wrk.dgn then deleting all unwanted 
graphics or creating a new DGN from seed.  The PROJ#sv.dgn is referenced into this file so 
existing topographical information can be obtained as needed. (i.e. survey points, location of 
breaklines, etc.)  

When a suitable alignment has been attained, a profile and cross sections are generated. The 
alignment information is copied into PROJ#nu1.dgn and the profile and cross sections are 
generated into PROJ#xs.dgn where the finishing touches are added for the submittals being 
prepared. The wrk file serves as a blank CAD drawing available to view geometry and surface 
information without the clutter of other active elements in the file.  Working in a blank drawing, 
allows for all levels ON, avoiding looking for certain data i.e. features, geometry, or stationing 
etc., not finding the data, then realizing that the level was turned off.  In many projects it is 
necessary for each designer working on the project to have their own wrk file adding their 
initials as a suffix to the file name.  Remember graphics in the any wrk file are never considered 
part of the project; this file is a blank slate for working InRoads Design. 

The wrk drawing file should never be submitted with new or proposed graphical data as part of 
the design. While the wrk file is often referenced by the nu1 it should never be the source of the 
design data.  No wrk file graphical data will be considered acceptable by VAOT, if it is part of 
the design it needs to be in the proper file i.e. nu1, xs1 etc.  We will not use or accept any data 
in the wrk file received from Consultants.  All wrk file graphical data is considered deficient or 
oddments; no exceptions. 

3.2. SETUP PROJECT DEFAULTS 

The Project Defaults command, located under File on the InRoads pull down menu, specifies 
which preferences files to open on InRoads startup, and can save multiple configurations i.e. 
Design Preferences vs. Survey Preferences and project specific with the logical paths to a 
specified or sets of specified directories for different data file types.  

T:\CADD\Workspace\Projects\English\InRoads\Prefs\VTcivil_1.xin  

T:\CADD\Workspace\Projects\English\InRoads\Prefs\VTcivil_sv.xin  

T:\CADD\Workspace\Projects\Metric\InRoads\Prefs\ (not available) 
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Click the new button, name the new configuration English, then click in the Preferences window 
then click < browse > locate the English VTcivil_1.xin file (as shown above) > Click Apply.  This 
is the typical preference file used on proposed projects designed in Imperial (English) units of 
measure.  As shown above other preference files such as the Rainfall Data (*.idf) files can be 
loaded from the project defaults dialog. 

In Addition to setting up an English Preference project default you can save a configuration 
specific to your project that will setup default directory paths related to the project you are 
working on.  On the bottom portion of the “Set Project Defaults” dialog box there are default 
directory paths which can be specified.   

If the project is English select an English configuration then click the copy button, next rename 
your copy of the configuration to the project name. Customize the configuration by selecting the 
window field to the right of the Project Default Directory, then click the browse button and select 
the project specific folder you wish to be directed to when opening up or saving InRoads files.  
Setting the “Project Default Directory” and “Projects (*.rwk) option will in most cases be enough 
unless you store DTM, ALG, TML etc. in data specific folders. 

Each time you open InRoads your last used 
Project Defaults will activate, verify you are 
loading the proper files for your project.  If you 
need to switch Project Defaults open the 
dialog click on the configuration name (in the 
pull down) appropriate to your project.  When 
you close (not X) the dialog the new defaults 
will be loaded.  

We continue to use the project *.rwk file to load alignments (.alg), surfaces (.dtm), Template 
Library (.itl) and Roadway Designer (.ird).  This is to insure that co-workers will have the ability 
to load all current design data when and if they need work on or use project data.  Project 
Defaults do not load data files, only preference files.  Data must be loaded by browsing to the 
files or using the project (.rwk) file. 

 

3.3. LOADING ORIGINAL GROUND DATA (dtm) 

Most Project Development projects have an original ground survey collected in the scoping 
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stages of the project design cycle.  This survey data is imported into InRoads Survey and a 
resulting survey drawing file is created showing topographical features of the project area.  This 
same survey data is used to create a Digital Terrain Model of the project area and any 
structures that may exist relating to the project.  This DTM will be the basics for design of the 
proposed surface and roadway geometry. 

3.3.1. Opening a DTM file 

a) Select File > Open. 

b) Set Files of type to Surfaces (*.dtm). 

c) Browse to the Survey original ground surface model.  For most projects the survey og 
DTM will be located in the Projects\PPMS#\Survey\ folder.  The proper name for a 
projects original ground DTM file is xPPMS#sv.dtm.  For more on proper file naming see 
the VAOT CSPM, file naming convention. 

d) Once the surface is loaded you can go to the surface tab of the InRoads workspace bar 
and select surface.   Information relative to the surface is displayed in the data window to 
the right. 

 

e) The original ground DTM is loaded and will be in read only status (unless you are a 
member of VAOT survey section).  This does not stop you from viewing or editing the 
original ground but you cannot save the changes. 

3.4. CREATE GEOMETRY PROJECT FILE (alg) 

a) Select File > New. 

b) Select the geometry tab on the top of the dialog. 

c) Set the Type: to geometry project. 

d) Type in the geometry project name > example: z85e088prop. 

e) Give the geometry project a Description > example: ROYALTON BRS 0147(13). 

f) Close the New dialog and go to the geometry tab on the workspace bar; < right click > 
on the geometry project you created, then click save.  

g) Browse to the project folder where you will save the geometry file, name the file, and 
click the save button.  The internal geometry project name z86e088prop is also the 
proper file naming convention for proposed geometry files with the added (.alg).  
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3.4.1. Create Horizontal & Vertical Geometry 

Horizontal geometries are children of the geometry project.  One geometry project can contain 
many defined horizontal geometries.  Vertical geometries are children of the horizontal 
geometry and grand children of the geometry project.  Horizontal geometry can contain many 
defined vertical geometries.  We will create two horizontal geometries one that is intended to 
match the existing roadway centerline, the other will define a new proposed alignment.  Each of 
these horizontals will contain at least one defined vertical alignment. 

a) Select File > New. 

b) Select the geometry tab. 

c) For the Type select horizontal geometry in the pull down window. 

d) Type in a proper name and description.  It is common practice to begin the name of the 
horizontal geometry with the proper route name such as VT100, I89 or US2 etc.  
Examples shown: 
 

 

e) Under the Description field is the Style: field select one of the predefined alignment 
styles. Alignment styles control the drawing display and level assignments for the 
geometry element, points and geometry annotations.  

f) Click the Apply button then change the Type: to vertical alignment. 

g) Name the vertical alignment > v1 and enter a good description for this vertical Definition.  
Verticals are children of the horizontal, the name of the horizontal will help define the 
vertical.  Vertical alignments are typically named v1, v2, v3.  It is also good practice to 
always have v1 the accepted vertical alignment.  This is to aid future users in knowing 
what vertical should be use.  Vertical alignments also have Style assignments the default 
or align1 is normally used for v1.  

h) Repeat this process for each horizontal definition needed in your project.  Remember 
one horizontal can have multiple verticals.  When creating verticals they are added to the 
active horizontal. 

3.4.2. Active Geometry 

When viewing geometry in the workspace bar you can < right click > and select Set Active to 
make a geometry the active geometry; the red outline indicates active status.  You can have 
only one geometry project, horizontal alignment, and vertical alignment active at any time.  The 
child parent structure effects active geometry i.e. if you choose to make a vertical alignment 
active, its parent horizontal will also become active; likewise its geometry project will become 
active if it resides in a separate geometry project. 
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3.5. CREATE TEMPLATE LIBRARY FILE (itl) 

At this point in the process we will create a project specific template library file.  Then save the 
file to the proper project folder.  We will not open the template library or create templates at this 
time.  Creating templates will be covered in a later section of this manual.  

a) From the workspace bar select the Template tab.   

b) Right Click on the Template Library entry in the workspace 
bar window. 

c) Select the New… option. 

d) A save as dialog appears.  Browse to your project location and save the file with the 
proper name.  In this example the proper name should be z85e055.itl.  No file 
description segment of the name is required since a project should only have one 
current template library file. 

3.6. CREATE ROADWAY DESIGNER FILE (ird) 

At this point in the process we will create a project specific roadway designer file.  Then save 
the file to the proper project folder.  We will not open the roadway designer or define any 
corridors at this time.  Defining roadway corridors will be covered in a later section of this 
manual. 

a) From the workspace bar select the Corridors tab.  

b) Right Click on the Roadway Designer entry in the w
bar window. 

c) Select the New… option. 

d) A save as dialog appears browse to your project location and save the file with the 
proper name.  In this example the proper name should be z85e055.ird.  No file 
description segment of the name is required since a project should only have one 
current Roadway Designer file. 

3.7. PROJECT FILE 

The project file contains directory and file information for loading and saving InRoads data files.  
Opening a project file opens all files specified (listed) in the Project File.  The save project file 
command saves all of the files specified (listed) to their respective file locations based on the 
information set in the Project Options dialog.  This file is an ASCII file that can be edited directly 
using an ASCII editor such as note pad. 

RWK 
DTM M:\Projects\86e055\Survey\x86e055og.dtm,N 
ALG M:\Projects\86e055\Consultants\InRoads\z86e055_27.alg 
ALG M:\Projects\86e055\Consultants\InRoads\z86e055_28.alg 
ITL M:\Projects\86e055\Consultants\InRoads\z86e055.itl 
IRD M:\Projects\86e055\Consultants\InRoads\z86e055.ird 

Shown here is the content of a project rwk file.  It is basically a list indicating where files are 
located and the name of the file.  Note the (,N) after the og.dtm is an option indicating the file is 
opened as read only and will not be saved when the save project command is used. 
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3.7.1. Create the rwk file. 

a) Make sure all the files needed in the project file are currently loaded into the InRoads 
session.  If you created something new but did not save the file to a specified location 
and give it a file name it will not be included in the project file. 

b) Select File > Save As 

c) In the save as dialog set the Save as type: to “Projects (*.rwk) 

d) Browse to the location where you will save this project file. 

e) Name the project file – example z86e055.rwk No file description segment of the name is 
required if a project should only have one current project file.  Some projects may have 
multiple project files but all projects should have at one that loads all current data. 

f) Click the Options… button on the bottom right corner of the save as dialog. 

o The Options dialog contains tabs for each of the file types that can be listed in 
the rwk file.  Each tab will list the currently loaded file with a toggle box indicating 
if the file should be tagged as Add and/or Update.  Add indicates that the file can 
be loaded using the rwk file; Update indicates that the file can be saved using 
the save project command. 

g) On Surface Tab toggle (on | Add) & (off | update) for og surface.  It may already be set 
by default 

h) On Geometry Project Tab (on | Add) & (on | update) for your project geometry file. 

i) On the XIN Preferences Tab (off | Add) & (off | update) for the VAOT standard 
preference file.  We use the project defaults to load all preferences not the rwk file. 

j) On the Template Library Tab (on | Add) & (on | update) for your project template file. 

k) On the Roadway Design Tab (on | Add) & (on | update) for your project roadway file. 

l) Click OK > Save > Cancel. 

As you add or create more data files such as proposed surface models you must update the 
project file by repeating the process above.  The options will remain as you initially set them but 
you will need to overwrite the old project file with the updated file.
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SECTION 4 – DIGITAL TERRAIN MODELS 

 
4. INTRODUCTION 

In the previous section you loaded an original ground DTM.  This section will discuss tools used 
to display and view as well as the structure of the Digital Terrain Model.  Throughout most of 
this section a DTM created from survey data is used, however these tools are applicable to any 
DTM loaded into InRoads.   

A DTM contains a series of defined triangles formed by surface points using a triangulation 
algorithm.  This algorithm, based on Delaunay's criteria, creates triangular planes that define the 
terrain surface.  Since the x,y,z coordinates of each triangle's vertices are known, the elevation 
of any point on the resulting triangular plane can be computed through interpolation given its x,y 
coordinates. 

This ability to interpolate elevations of any point allows for a virtual surface that can be 
displayed and viewed in numerous ways to suit needs during the design process.  This section 
will discuss common methods for viewing surface data including: 

• The Perimeter 
• Triangles (Wire frame and Rendered) 
• Contours and Contour Elevations 
• Surface Elevations 
• Feature Properties 
 

4.1. SURFACE > VIEW SURFACE TOOLS 

Open the surface you are planning to view, if not already open.  For information on opening 
surfaces see Section 3 of this manual.  You should be in a working design file as defined in 
Section 3 of this manual with all levels ON.  The InRoads main menu contains a Surface menu; 
this is where the View Surface > tools are located.  There are however, other tools that use 
surface data including Evaluation and Modeler commands. 

4.1.1. The Perimeter 

a) Select Surface > View Surface > Perimeter.    

b) Set the appropriate surface active in this 
example x86e055og is the surface that will 
have its perimeter generated. 

c) Select Preference Tab.  To load a named 
preference, double click on the name of the 
preference.  The old_ground preference is 
standard for the original ground DTMs.  Named 
preferences (Perimeter Surf-1 through Perimeter Surf-5) are used to achieve levels 
separation of perimeter graphics.  Select and load the old_ground preference. > Close 
the Preference dialog.  

d) Click the Apply button.  An outline of the triangulated model will be displayed in the 
active DGN view.  Close the View Perimeter dialog. 

By definition the perimeter is a graphical display of the outside or exterior edge of the current 
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triangles as they reside in the model.  This graphical display does not control the triangles it only 
identifies the perimeter of the current triangles.  This is not the same an exterior boundary 
feature, even though they often appear in the same spatial location.   

4.2. DTM TRIANGULATION 

Triangles are a very good way to dynamically view the 3D surface.  Viewing the triangles lets 
you see elevation breaks, river channels and much more.  Rendering the triangles gets you an 
even greater visualization of existing surface model conditions.  This method of viewing the 
surface is excellent for analyzing and checking the existing surface or proposed surfaces for 
errors or problem areas. 

 

Shown here is an example surface triangulation display.  Each triangle vertices has a known 
x,y,z coordinate.  The triangulated model is the basis for surface display and surface 
computations made by InRoads.  Surface reporting, quantity information, and evaluation data is 
only as good as the triangulated models they are referencing. 

4.2.1. View Triangles 

a) Select Surface > View Surface > Triangles.    

b) Set the appropriate surface active in this 
example x86e055og is the surface that will be 
represented by the triangles. 

c) Select Preference Tab.  To load a named 
preference, double click on the name of the 
preference.  The old_ground preference is 
standard for the original ground DTMs.  Named 
preferences (Surf-1 through Surf-5) are used to achieve levels separation of triangle 
graphics.  Select and load the old_ground preference > Close the Preference dialog.  

d) Click the apply button.  Triangles that represent the surface model will be displayed in 
the active DGN view.  Close the View Triangles dialog. 

4.3. CONTOUR DISPLAY 

a) Select Surface > View Surface > Contours.    

b) Set the appropriate surface active in this example x86e055og is the surface that will be 
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represented by contours.  

c) The Interval: sets the contour interval.  This 
number represents the vertical change in 
elevation that will be represented by a 
contour line.  In this case 2 will generate a 
contour line at every 2 foot change in 
elevation. 

d) Minors per Majors:  sets the number of 
minor contours that will be displayed 
between the major contours.  The settings 
shown here will generate a contour line e
2 ft with 4 minors per major resulting in a 
major contour every 10 ft. 

e) Select Preference Tab.  To load a named 
preference, double click on the name of the 
preference.  The old_ground preference is 
standard for the original ground DTMs.  
Named preferences (Cont Surf-1 through 
Cont Surf-5) are used to achieve levels 
separation of contour graphics.  Select and 
load the old_ground preference > Close the 
Preference dialog. 

f) In the symbology section of the dialog notice 
that Major, Minor, and Major Labels are “X” 
to indicate they are ON and will be displayed 
when applied.  Click the Apply button > 
Close the View Contours dialog. 

g) Shown here is an example of contours drawn at 2 ft intervals with majors at 10 ft interval 
and labels on the major contours.  This is the default contour spacing, other contour 
intervals may be required on very flat or very steep areas.   

h) To change the contour interval to a 1 ft interval with labeled majors at 10 ft. 

1) Change the Interval: number to 1 for one foot > Click the TAB key. 

2) Change the Minors per Major: to 9 > Click the TAB key. 

3) Click the Apply button or (Enter key) > Close the Dialog 

Note:  Typically for InRoads the ENTER key is equivalent to the Apply button on a dialog.  Use 
the TAB key to enter or accept input entries in dialog fields.  If you click the ENTER key the 
command will initiate.  This is particularly important on the more complex dialogs with lots of 
options where initiating the command prior to completing input may cause undesirable changes 
to your data.  
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d. 

d) Click the Apply Button > Click the Close Button.  

by a data point on the 

f) Click Apply > Hold the MicroStation cursor over and data point or snap to the point and a 

4.4. SURFACE POINT ELEVATIONS 

As stated earlier the triangulated model allows for the elevation of any point on the resulting 
triangular plane to be computed through interpolation given its x,y coordinates.  The surface 
elevation tools will label the elevation of any given coordinate over a surface model.  There are 
several options or methods used for labeling elevations.  The simplest is to label all points on a 
given surface model. 

a)  Select Surface > View Surface > Surface Elevations. 

b) Set the appropriate surface active in this example x86e055og is the surface that will be 
represented by point elevations. 

c) By default All Points is the active mode and should be fine for small surface models. 

1) For large surface models place a 
MicroStation fence around the area 
elevations are to be labels. 

2) When you have a MicroStation fence 
active the Fence Mode option a
with inside mode as the default 
preference.  This indicates that only 
points inside the fence will be labele

e) Single point elevation can be labeled at any point specified 
screen.  Select Surface > View Surface > Single Point > Surface Elevation. 

single point elevation will be labeled. 
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4.5. FEATURE PROPERTIES 

To this point we have referred to surface models as points connected by a series of triangle legs 
that form a virtual surface model that can be utilized for multiple purposes.  There is more to the 
DTM then points.  Point data can be tagged as specific point types and connected to other 
points of the same type forming a feature.  For example, a series of points can be connected to 
form a crown of the road feature.  This type of point data is called a breakline.  A breakline is 
unique in that no triangle legs are allowed to cross a breakline.  This adds control to the 
triangulation by specifying that certain linear features have different feature types.  Breaklines 
are the most common feature type in civil site work.  Features and points can also be tagged as 
do not triangulate, they will be saved in the DTM but will be ignored for the triangulation. 

Breaklines provide enhanced accuracy to the surface models defining edges, corners, ridges, 
exterior and interior boundaries etc.  Breakline triangle legs are formed prior to non breakline 
triangle legs, resulting in each linear breakline point connection forming a leg of the resultant 
triangulated model.  The triangulation process alone will connect each point to the nearest point 
in the x,y plane, allowing no one triangle leg to cross another.  Breaklines override the 
triangulation process of finding the nearest point in the x,y plane. 

Breakline features formm the VAOT survey topographical drawing.  Graphical elements shown 
in each projects survey file are representations of breaklines collected by a field survey.  To 
view or edit surface model (DTM) feature properties: 

a) In your MicroStation View turn on all level.  Turn off all reference files. 

b) Select Surface > View Surface > Feature > Feature Properties. 

c) In the Feature: list scroll down to a feature named CR*.  CR is the VAOT survey alpha 
code for Crown of the Road.  Select one of the CR* features.  Note the Triangulation 
Feature type is Breakline. 

d) Select all the features with the CR* name.  Notice the features are highlighted in the 
active DGN view. 

Viewing and editing feature properties will be much more valuable on proposed surface models.  
In order to create accurate complete proposed surface models you will need a comprehensive 
understanding of features and their properties.  More information is available from InRoads help 
and should be explored.
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SECTION 5 – HORIZONTAL GEOMETRY 

 
5. INTRODUCTION 

The basis for laying out a roadway is the horizontal control geometry.  This consists mainly of 
defining the straight and curved sections in the roadway design.  Roadway design is tied to 
horizontal control geometry.  Often the horizontal geometry is the center or crown of the road.  
Horizontal geometry affects the speed and safety of a roadway design.  Proper engineering 
design of roadways is important and should follow state and federal guidelines.  The Vermont 
Agency of Transportation relies on several sources for Engineering Design References.  

• VAOT Road Design Manual 
• VAOT Structures Manual  
• AASHTO Roadside Design Guide 
• VAOT Standards Drawings 
 

These are some of the basic reference materials but there are many more engineering 
reference materials used during the design process.  Section 5 will focus on the basic InRoads 
tools used to layout horizontal control geometry not on engineering design practices. 
 
5.1. LAYOUT CURVE SET TANGENTS 

The PI method for layout of horizontal geometry seems to work for most standard VAOT 
roadway layouts.  This method involves defining horizontal tangent line Points of Intersection.  
For most projects we start by defining a horizontal geometry that matches the existing roadway 
design.  The original ground survey drawing is used as a reference for locating existing 
geometry tangents and the PI’s.  
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Shown here in Figure 5.1a is an example of 4 tangent lines defined by 5 PI’s.  PI – 1 defines the 
POB or point of beginning on this alignment while PI -2 is a true point of intersection.  These five 
points were defined using the insert PI command.   

In Section 3.4 the process for creating a Geometry Project and naming a Horizontal Geometry 
was explained.  The next section will walk through the process for defining the elements that 
make-up horizontal geometry.  

5.1.1. Add PI - Define Point of Intersection (PI) 

a) Set the appropriate horizontal geometry active.  For this example set VT14prop_1 as 
the active horizontal alignment. 

b) Turn ON all DGN file levels. Turn ON the survey original ground reference. 

c) Select Geometry > Horizontal Curve Set > Add PI 

d) For PI-1 data point on the center of the existing roadway at the beginning of the project 
then data point to accept the point.  NOTE: always read and follow the MicroStation 
prompts at the bottom left corner of the application. 

e) After accepting PI-1 you will automatically be asked to select the next point.  A dynamic 
display of the geometry tangent should follow the curser to the next point.  Following the 
existing topographical drawing, data point and accept the location of PI-2 (See Figure 
5.1a).  PI-2 is not on the roadway center line it is where the first tangent will intersect the 
second tangent.  It is not critical that PI’s be placed exactly in the proper position on the 
first attempt.  PI’s can be moved to best fit a design. 

f) Work your way along the project data pointing and accepting PI locations similar to what 
is shown in Figure 5.1a. 

g) It is a good practice to delete the graphics generated after creating geometry, and then 
redisplay the alignment elements.  This will ensure that the saved alignment is the same 
as what is shown on the screen.  Do not assume graphical elements shown on the 
screen are the same as what is in memory.  When uncertain re-display the alignment 
elements.   

• To re-display geometry Select > Geometry > View Geometry > Active Horizontal. 

Geometry can be reviewed in detail using the Review Horizontal Alignment command.  This 
data can be saved in a text file or printed for review and project records.  

a) Set the active horizontal geometry appropriately.  For this example set VT14prop_1 as 
the active horizontal alignment. 

b) Select Geometry > Review Horizontal. 

Shown below is the content of a Review Horizontal Alignment command.  This is a review of the 
geometry placed and shown in Figure 5.1a.  Note that PI-1 is represented as the POB.  The first 
element spans from POB (1) to PI (2) then the second element spans from PI (2) to PI(3) and so 
on.  The Stationing, Northing and Easting of each point is listed.  The direction of each element 
and its length are also reported.  Notice there are different modes available for reviewing the 
geometry.  As the geometry is extended and curves are defined these review modes will 
become very useful.  This review information can be used to re-create the exact geometry (if 
required) using MicroStation precision key-in commands to place each PI. 
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             Project Name: z86e055prop 
              Description: Proposed Geometry 
Horizontal Alignment Name: VT14prop_1 
              Description: VT14 On Alignment Option 
                    Style: align1 
                                       STATION      NORTHING       EASTING 
 
Element: Linear   
             POB (       1)            0+00.00   491864.1400  1617790.0592 
              PI (       2)            1+39.36   491827.5670  1617655.5806 
         Tangent Direction:   S 74^47'08.57" W 
            Tangent Length:             139.36 
 
Element: Linear   
              PI (       2)            1+39.36   491827.5670  1617655.5806 
              PI (       3)            8+41.68   491759.4683  1616956.5692 
         Tangent Direction:   S 84^26'08.60" W 
            Tangent Length:             702.32 
 
Element: Linear   
              PI (       3)            8+41.68   491759.4683  1616956.5692 
              PI (       4)           16+37.44   491074.5200  1617361.6296 
         Tangent Direction:   S 30^35'56.23" E 
            Tangent Length:             795.76 
 
Element: Linear   
              PI (       4)           16+37.44   491074.5200  1617361.6296 
             POE (       5)           20+28.97   490694.4224  1617455.5598 
         Tangent Direction:   S 13^52'51.28" E 
            Tangent Length:             391.53 
 

Note: The process for creating the horizontal geometry can be iterative.  In some cases the 
POB of the alignment then the POE (Point of Ending) are placed before any other PI points.  
The sequence for placing points does not matter.  Place points where they seem reasonable, 
then insert and move points to get the desired alignment. 

5.1.2. Insert PI 

Use this command to insert a PI between two existing PI locations.  

• Select Geometry > Horizontal Curve Set > Insert PI (Read and Follow the 
MicroStation Command Line readout) 

• Redisplay geometry Select > Geometry > View Geometry > Active Horizontal. 

5.1.3. Move PI 

Use this command to move a PI that existing in the active alignment. 

• Select Geometry > Horizontal Curve Set > Move PI 

• Redisplay geometry Select > Geometry > View Geometry > Active Horizontal. 

5.1.4. Delete PI 

Use this command to delete a PI that existing in the active alignment. 

• Select Geometry > Horizontal Curve Set > Delete PI  

• Redisplay geometry Select > Geometry > View Geometry > Active Horizontal. 
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5.2. DEFINE CURVES 

Defining a curve between tangent lines is an important part of the horizontal alignment.  We will 
use the define curve command and review several of the options that can be used to set and 
refine the proper curve radius.  There are other tools available to generate horizontal alignments 
and curve sets.  The other geometry tools available are more advanced and can be very useful 
for more complex geometry such as compound curves. 

5.2.1. Radius 

To use the Define curve by radius command you must have tangent elements defined in your 
active horizontal alignment. 

a) Select Geometry > Horizontal Curve 
Set > Define Curve. 

b) On the Define Horizontal Curve Set 
dialog are several options.  At the 
bottom notice the next > Last and 
Select curve navigation buttons.  If 
you click the Next > button you walk 
down your alignment PI points.  If 
you watch your MicroStation view 
each PI tangent set will highlight as 
they become the active curve.   

c) Above the curve navigation buttons i
the Define By: Toggle on the Ra
option. 

d) Above the Define By: section is the 
Horizontal Curve section here you 
will enter in curve information. 

e) Go to the First curve set in the 
horizontal alignment.  Notice the 
curve radius is set to 0.00 if you h
not changed it.  Enter in a 
reasonable curve radius for your 
project.  Click the TAB key to enter 
the data > Click the Apply button.   

f) The curve should dynamically 
display the curve radius on the screen.  If your radius is too large the software will not 
accept it and notify you of a solution overlap.   

5.2.2. Point on Curve 

Often for matching into existing project curves the quickest way to find a radius is to identify a 
point through witch you need the curve to pass through.  This can be done using the Point on 
Curve method. 

g) Select Geometry > Horizontal Curve Set > Define Curve. 

h) Navigate to the curve using the <Previous, Next> or Select buttons on the bottom of the 
dialog. 

i) Toggle on the Define By: Point on Curve option.  
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j) Use the target button to the right 
of the coordinate display to 
select a location the curve will 
pass through. 

k) Click the Apply button.   

l) Toggle the Define By: option back to Radius.  You can now edit the radius to refine the 
curve definition. 

Note:  If you attempt to define a radius that is too large the software will not find a solution.  
Adjust your parameters and try again.  You can move PI locations after curves have been 
defined.   

5.2.3. Curve Calculator 

The curve calculator computes parameters of a curve based on two known parameters. This is 
used primarily in association with other commands to compute the length and radius of circles 
or spirals when given known parameters.    

To calculate the DOC of a curve for a given radius lock the radius value in the calculator and 
lock in one of the other parameters i.e. Length:, Angle:, Chord:, etc. an click the Compute 
button.   

To calculate a Radius for a given DOC Lock in the desired DOC and one of the other 
parameters (make sure the Radius is unlocked) click the Compute button. 

When you have computed the results click the OK button.  Computed values will be entered into 
the Define Curve Set dialog.  Click the Apply button to apply the defined parameters to the 
curve. 

Description Parameter DOC Radius (FT) 

Radius (R) Radius 1 5,729.6 
2 2,864.8 Degree of 

Curve DOC 
3 1,909.9 

Arc (A-B) Length 4 1,432.4 
Angle (Δ) Angle 5 1,145.9 
Chord (A-B) Chord 10 573.0 
Tangent (T) Tangent 15 382.0 
Distance (E) External 20 286.5 
Distance (M) Ordinate 25 229.2 
  30 191.0 
  40 143.2 
  50 114.6 
  60 95.5 
  

SIMPLE CURVE 
 

 
 90 63.7 
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5.3. ALIGNMENT STATIONING 

Stationing is linear horizontal measurement along the horizontal alignment, where a defined 
linear length value is assigned to a point on the geometry.  All points along the geometry are 
measured relative to the assigned stationing value.  This forms a relative method of reference 
for all transactions related to the geometry. 

General Stationing Rules: 

• No Roadway horizontal alignment should start with a 0+00 Stationing value. 

• Roadways should have significantly distinct stationing values e.g. 500+00 vs. 600+00.  

• Existing Stationing should be matched when possible. 

5.3.1. Define Stationing 

When ready to define the stationing for alignments, set the horizontal alignment active.  By 
default the first PI placed in the geometry will have station 0+00.  PI’s added to the first PI 
placed will have negative station values; stations added after or inserted between the POB and 
POE will have positive values.  We can define the stationing value at any single point in the 
geometry.  Generally it is sufficient to define the stationing for the POB. 

a) Select > Geometry > Horizontal Curve Set > Stationing. 

b) In the Stationing dialog you can select the Horizontal Alignment e.g. set to VT14prop_1. 

c) In the Starting Station field enter the stationing value for your alignment e.g. 500+00.  It 
is not required to type the (+). 

d) By default you are defining the stationing for the POB if you need to select an alternate 
point or location you can do so with the target button to the right of the point name field. 

e) Vertical and Superelevation Alignments options should be set to Maintain Station 
Difference unless you are specifically attempting to shift alignment stationing. 

f) Click Apply 

g) Review the Horizontal Alignment, in the Review Dialog note that the POB now has a 
station value of 500+00. 

             Project Name: z86e055prop 
              Description: Proposed Geometry 
Horizontal Alignment Name: VT14prop_1 
              Description: VT14 On Alignment Option 
                    Style: align1 
                                       STATION      NORTHING       EASTING 
 
Element: Linear   
             POB (       1)          500+00.00   491864.1400  1617790.0592 
              PC (       2)          500+68.88   491846.0640  1617723.5941 
         Tangent Direction:   S 74^47'08.57" W 
            Tangent Length:              68.88 

h) Select > Geometry > View Geometry > Stationing. 

i) Select the appropriate Horizontal Alignment e.g. set to VT14prop_1. The limits toggle off 
will station the entire alignment. 

j) The default preference will generate stationing graphics for general use, in the 
preference option there are several predefined preferences aling1-5 for general 
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alignment stationing and the Title stationing for title sheet specific stationing.  Load the 
aling1 preference > Close 

k) Click the apply button.  Stationing will be generated in a standard VAOT format.   

 

There are many options for stationing found on the View Stationing dialog.  These options can 
change what is getting station labels such as Major or Minor Stations.  You can rotate the 
direction of the station labels under the regular station labels tab.  This is sometimes needed 
depending on the rotation of your project layout.  The image above shows typical stationing. 

5.3.2. Tracking Tools 

The Tracking Tools track along the active Horizontal and Vertical geometry dynamically and/or 
graphically displaying information relative to the geometry. 

l) Select > Tools > Tracking > Horizontal Alignment. 

m) Move your cursor or snap to a location on the screen.  The information display at the 
bottom of the InRoads Explorer will dynamically display Station, Offset and Elevation of 
the active horizontal alignment.  The elevation portion will show the elevation of the 
Active vertical alignment.  If you have no vertical the Elevation should display as Zero. 

n) Select > Tools > Tracking > Tracking > Activate. 

o) This will dynamically display tracking information in the Tracking dialog and if you select 
a location on the screen the information will be written to the screen in MicroStation 
Graphics. Note the elevation shown with this tool is the elevation of the Active surface.  

5.3.3. Station Equations 

Station equations denote a change in stationing along an alignment due to a change in length of 
the alignment. A change in length can occur for example when a revision to a project flattens a 
curve, straightens a section of roadway, or in some other way alters the road so that it is longer 
or shorter than its original length. Instead of re-stationing the entire roadway, a station equation 
is created so that as little of the road as possible requires re-stationing.  For more information on 
Station Equation setup refer to the InRoads help. 
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5.4. DEFINE EVENT POINTS 

There are a number of reasons to add event points to the horizontal alignment.  Events are 
basically points of interest i.e begin project location, end project location, roadway intersections, 
driveway intersections, begin bridge, end bridge etc.  Event points can be defined by Station 
and Offset values, Northing and Easting values or Cogo Points.  Events are reported in the 
geometry reports and can be annotated graphically along with other geometry point annotations. 

a) Set active horizontal geometry e.g. VT14prop_1 

b) Select > Geometry > Horizontal Curve Set > Events. 

c)  Define By: > Single Station 

d) Add As > Station and Offset. 

e) Locate By: you can use the target to select a location or enter the proper station and 
offset.  In this example I will enter the station as 502+00 with an offset of 0.00 this event 
will help define the begin project. 

This event is tied to the stationing if the stationing is changed this point will follow and remain at 
station 502+00.  If you define events using the “Add As” Station and Offset (S+O) method then 
change the stationing of the geometry such that the event points are outside the range of the 
horizontal geometry the events are deleted. 

Defining a point by Northing and Easting will store the point using its coordinate value.  If the 
stationing on the alignment changes it does not change the event point coordinate values. 

Note: Horizontal geometry should extend beyond the construction limits, i.e. where the project 
will start and stop.  Vertical alignments are not required to extend beyond but should include the 
start and stop points. 

5.5. HORIZONTAL ANNOTATION 

The Horizontal Annotation tool provides an expanded ability to display and annotate.  These 
tools provide the ability to display multiple horizontals at the same time as well as display all the 
different point and element types.  Preferences have been setup GP_ALIGN-1 through 
GP_ALING-5 these preferences basically are the same settings but the display is generated on 
the appropriate alignment control levels i.e. AC1_P through AC5_P. 

a) Select > Geometry > View Geometry > Horizontal Annotation 

b) Select > Preference button > Load the GP_ALIGN-1 
preference > Close. 

c) Select in the Horizontal Alignment Include field.  

d) Select the Filter Button (Top Right near Help). 

e) In the Geometry Selection Filter to the left are all available horizontal 
geometries.  To the Right are the selected geometries.  Using the Add, 
Remove, Swap, None and All buttons put the geometry you are annotating on the 
selected side of the dialog. Click OK.   

f) Click the Apply button on the View Horizontal Annotation Dialog.  The selected geometry 
is displayed with additional data including the Subtangents.  This is a standard VAOT 
horizontal annotation on the new and proposed design plans. 
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5.6. REVIEW AND REPORT HORIZONTAL GEOMETRY 

The review horizontal geometry dialog displays detailed information about the elements in the 
selected horizontal alignment.   

a) Select Geometry > Review Horizontal 

b) Geometry Project Field is used to specify the geometry project that contains the 
Horizontal alignment you want to review. 

c) Horizontal Alignment field is used to specify the Horizontal alignment you want to review.  
The target button can be used to tag the horizontal alignment elements on the screen. 

d) Mode: area will filter what parts of the alignment you are reviewing.  

 

o Curve Sets option will display information based on curve sets. 

o Alignment will display all elements in the specified Alignment. 

o Element option will display one element in the alignment at a 
time.  The Select, First, Previous, Next and Last buttons can be 
used to view each element in the alignment.  The element 
currently being reviewed is highlighted in the current view.  

The save as command will save the current review contents to an ASCII file.  It 
is good practice to save the Alignment review to file in the project folder and print it out for the 
project file.   

5.6.1. Report Horizontal Geometry 

XML Reports offer a long list of report capabilities.  Using XML reports we can choose from 
standard delivered InRoads Style sheets and if so inclined you can create your own XML style 
sheets.   

a) Select Tools > XML Reports > Geometry. 

b) Select the Include field > Filter > Use the Add, Remove, Swap, None and All buttons to 
get the geometry you are reporting on in the Selected window. Click OK 

c) Alternatively if you know the name of the alignment you could type it into the Include 
field, or use the target to graphically select the alignment. 

d) Click the Apply Button. 

e) The Report browser will start.  On the left side you will see a list of available reports in 
the geometry folder.  HorizontalAlingmentReview.xsl sheet will give a report very similar 
to the standard review horizontal command but with format options. 

f) In the report browser select Tools > Format Options > Here you can adjust the Angular 
mode, Precision and change the format.  These changes are instantly shown in the 
report browser.  

g) Under the Report Browse File menu there are options for Printing or saving the report. 
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SECTION 6 –VERTICAL GEOMETRY & PROFILES 

 
6. INTRODUCTION 

Roadway horizontal geometry will require vertical control.  The vertical geometry will define the 
grade of the roadway and the vertical curves.  Using a profile generated along a defined 
horizontal geometry we can layout and design the vertical geometry.  Vertical geometry is the 
defined vertical data at or relative to the horizontal control geometry.  Proper engineering design 
of roadway vertical control is important and should follow state and federal guidelines.  The 
same engineering practices explained in Section 5 apply to this section.  Section 6 will focus on 
the basic InRoads tools used to layout vertical control geometry not on engineering design 
practices. 

6.1. CREATE A PROFILE ALONG HORIZONTAL GEOMETRY 

Vertical geometry requires an existing horizontal geometry to be defined and set active.  
Generating a profile along the horizontal geometry is also required before you can begin to 
define the vertical geometry.  This profile will be considered a working profile and should be 
generated in your working DGN file as defined in Section 3 of this manual.  Once the vertical 
geometry is designed and finalized a PROFILE is generated and annotated in your profile DGN 
for engineering plan set use.  For this section we will use the profile only as a means to define 
the vertical geometry when finished the profile can be deleted. 

6.1.1. Evaluation Profile Create Profile 

a) Load all data files; you will need the existing ground DTM file and the Geometry Project 
file as a minimum to generate this profile. 

b) Select Evaluation > 
Profile > Create Profile  

c) On the General Leaf 
Toggle ON the og 
surface  

d) The Exaggeration value 
by default is set at a 
value of 2 in this working 
example it was changed 
to 10 because of the relative flatness of the project.  Set your vertical exaggeration 
accordingly. 

e) On the Source Leaf the Alignment 
option should be toggled on and 
the horizontal alignment that the 
profile will follow should be set 
active e.g. VT14prop_1. 

f) There are many other options available to set in the create profile dialog.  Preferences 
have been setup for the VAOT standard profile generations including the default 
preference.  Click the Apply Button. 

g) Data point on the screen the point where you want the bottom left corner of the profile to 
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be drawn. (horizontal & vertical axis always align with the drawing X,Y axis)  

6.2. CREATE VERTICAL GEOMETRY 

Section 3.4.1 of this manual explains the process for creating and naming a Vertical Geometry.  
At this point you should have an empty vertical geometry created and named as a child of the 
Horizontal geometry that was used to create the profile. 

• If you do not have a vertical geometry created and named refer back to Section 3.4.1 or 
follow the steps shown below. 

• If you have a vertical geometry but it is not empty create another vertical geometry or 
empty the one you have.  You can review the vertical geometry using the Geometry > 
Review Vertical Geometry command (It should be empty at this point). 

o To create Vertical geometry use the File > New > Geometry Tab 
> Type: set to Vertical Geometry > Name the Vertical Geometry 
and set the Style > Click Apply. 

o To Empty a Vertical geometry use the InRoads explorer 
Geometry Tab > Select the vertical geometry and RIGHT CLICK; 
you will get a short cut menu with several useful tools including
the Empty command.  

 

6.3. DEFINE VERTICAL CURVES 

To begin defining the vertical curve we must realize that the vertical alignment must match into 
existing ground at begin and end of project.  For this reason we will start the vertical geometry 
by defining the begin and end points to match existing grade. 

6.3.1. Annotate Existing Ground elevations 

• Select Evaluation > Profile > Annotate Profile > Preference Button > Load the existing 
preference > Close. 

• In the annotate profile dialog Surface should be set to Existing Ground and the active 
profile set should be set and outlined on the screen if not use the target to select and 
activate it. Click Apply 

6.3.2. Add Vertical PI 

a) Select > Geometry > Vertical Curve Set > Add PI 

b) In the Add Vertical PI dialog toggle off the Dynamic rounding toggles, Click Apply, use 
the MicroStation key-in window and key-in SE= Station and Elevation of the beginning 
point of the vertical alignment e.g. 
SE=50025,530.6.  This can be read 
from the profiles horizontal axis.  Click 
the Enter Key.  

c) Read and follow the MicroStation 
command prompt to accept (data point) 
the PI location. 

d) Repeat the MicroStation Key-in with the Ending station and elevation of the vertical 
alignment e.g. SE=51675,526.6 [enter]. 

e) Above is one method for entering in VPI locations you could use the Add Vertical PI 
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Dynamics or select locations within the profile.  

6.3.3. Insert Vertical PI 

To this point we have a Vertical alignment with a constant grade from the begin project to the 
end project.  In a workflow similar to inserting or adding PI location in a horizontal alignment we 
will add or insert VPI locations to the vertical alignment.   

a) Select > Geometry > Vertical Curve Set > Insert PI 

b) In the Insert Vertical PI dialog you can set Dynamics for rounding the Stations, 
Elevations etc. then click the Apply button. 

c) Select on the screen the geometry element you are inserting the PI in and you will get a 
rubber banding display of the grade lines.  Data point and accept the location of the new 
PI.  Repeat this process for all PIs in the vertical alignment.  PI locations can be move 
and adjusted as needed to achieve the proper design. 

6.3.4. Move Vertical PI 

Use this command to identify and move VPI station and elevations using similar tools to what 
was used in creating the VPIs 

6.3.5. Delete Vertical PI 

Use this command to identify and delete VPI one at a time in the vertical alignment. 

6.3.6. Define Vertical Curve 

a) Select > Geometry > Vertical Curve Set 
> Define Curve 

b) This dialog is similar in function to the 
Define Horizontal Curve.  But Vertical 
curve parameters are parabolic.   

c) The Station and Elevation of a VPI can 
be edited from this dialog.  

d) Vertical Curve can be calculated using 
several methods including by Length of 
the curve, Rate of change, Middle 
Ordinate, Pass-through point, K value, 
Unsymmetrical Length. 

e) The active curve set will highlight in the 
profile to help identify the curve you are 
working on. 

f) Defining and refining a vertical geometry can be iterative.  It is important to note that one 
horizontal alignment can have several alternate vertical alignments defined.   

g) Save your geometry project whenever you get definitions that you would like to keep.  All 
software has the potential of crashing especially when you have large data sets. 

6.4. DEFINE VERTICAL EVENT POINTS 

Vertical Event points basically serve the same purpose as horizontal events; they define events 
that are specific to the vertical geometry.  Now that we have both a Horizontal and Vertical 
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alignment defined it is possible to add events as both horizontal and vertical events at the same 
time using the toggles located in each of the Define Events dialogs.  Vertical Events can be 
annotated in the profile. 

6.5. VERTICAL GEOMETRY ANNOTATION 

Vertical Geometry Annotation is the annotation of vertical elements in profile.  During the design 
process this annotation is one method for reviewing the geometry.  This is the standard method 
for showing vertical geometry in construction plan sets.  Profile sets are generated for every 
section of roadway in the project.  Generally each plan sheet has a matching profile sheet e.g. if 
a plan layout sheet is showing a section of road from STA 502+00 to STA 508+00 then a profile 
sheet should be setup to display vertical geometry from STA 502+00 to STA 508+00.  In some 
situations such as VAOT bridge projects plan and profile are shown on the same sheet. 

Shown here is a short example of a profile with the vertical geometry displayed and annotated.  
As shown it is standard to label the Length (L) of the curve, K value, stopping Sight Distance 
(SSD), stations and elevation of the PVC, PVI and PVT, as well as the entrance and exit 
grades.  The profile is annotated with the elevation of the existing ground and the proposed 
vertical alignment at 25 foot station marks on the bottom horizontal axis. 

 



VAOT InRoads Fundamentals Manual----------------------------------------------------------------------------------------------------------------------2007 
 

VAOT_IFM Page 37 2/20/2007 

6.5.1. Vertical Annotation  

a) Select Geometry > View Geometry > Vertical 
Annotation  

b) In this dialog you will set the proper horizontal 
alignment that contains the vertical you are planning 
to annotate e.g. VT14prop_1.  

c) Set the Vertical Alignment to the one you are planning to annotate e.g. v1. 

d) Set the Profile set to the proper profile in your drawing.  This option is used if there is 
more than one profile drawn.  Select the profile set you are using to display vertical 
annotation, a box should display around the profile set you are working on. 

e) Click the Apply button.  Vertical annotations may need to be moved around and cleaned 
up, some curve data and other annotations may conflict with each other, this is normal. 

6.6. PROFILE ANNOTATIONS 

In a previous section we utilized the profile annotation tools to label the elevation of the existing 
ground.  Now we will use some of the other Profile annotation tools. 

a) Select Evaluation > Profile > Annotate Profile. 

b) Click the Preference button > Load the Existing/Proposed named preference. 

c) Close the Preferences dialog. 

d) Set the Profile set to the proper profile in your drawing.  This option is used if there is 
more than one profile drawn.  Select the profile set you are annotating, a box should 
display around the profile set you are working on. 

e) Set the Vertical Alignment: appropriately e.g. v1.  This is where the proposed elevation 
data will be calculated from. 

f) Set the Surface: to the original ground DTM e.g. x86e055og.  This is where the existing 
elevation data will be calculated from.  Any surface loaded in this field will get displayed 
as the existing elevation. 

g) Click the Apply button, elevations are shown on level XANNOT_P_T, existing is shown 
with line weight 0 with an accuracy shown to the 1/10 place; proposed is shown with line 
weight 1 with an accuracy to the 1/100 place. 

6.7. REVIEWING AND REPORTING VERTICAL GEOMETRY 

The review and reporting capability for the vertical geometry is basically the same process as 
the horizontal geometry.  When creating XML reports the vertical geometry report is available 
separate from the horizontal or in the same report. 
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6.8. Review Vertical 

a) Select Geometry > Review Vertical  

b) The review report dialog appears, it can be use in the Alignment mode or an Element by 
element mode. Shown below is the Alignment mode review for the section of the vertical 
alignment shown previously in Section 6.5.  Note, the Vertical POB and the Horizontal 
POB are not at the same station; the horizontal POB was set to be STA 500+00.  This is 
normal the vertical alignments cannot extend outside the extent of the horizontal and 
usually starts some distance inside, near the begin project location. 

             Project Name: z86e055prop 
              Description: Proposed Geometry 
Horizontal Alignment Name: VT14prop_1 
              Description: VT14 On Alignment Option 
                    Style: align1 
  Vertical Alignment Name: v1 
              Description: VT14 On Alignment Option 
                    Style: align1 
                                       STATION         ELEVATION 
 
Element: Linear   
                         POB         500+25.00            530.60 
                         PVC         504+25.00            524.62 
             Tangent Grade:              -1.49 
            Tangent Length:             400.00 
 
Element: Parabola 
                         PVC         504+25.00            524.62 
                         PVI         505+00.00            523.50 
                         PVT         505+75.00            524.59 
                        VLOW         505+00.92            524.05 
                    Length:             150.00 
  Headlight Sight Distance:             350.34 
            Entrance Grade:              -1.49 
                Exit Grade:               1.46 
       r = ( g2 - g1 ) / L:               1.97 
       K = l / ( g2 - g1 ):              50.79 
           Middle Ordinate:               0.55 
 
Element: Linear   
                         PVT         505+75.00            524.59 
                         PVC         507+35.00            526.93 
             Tangent Grade:               1.46 
            Tangent Length:             160.00 
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SECTION 7 – CONSTRUCTING ROADWAY TEMPLATES 

 
7. INTRODUCTION 

Templates are used to define the transverse geometry of the Roadway or corridor.  Transverse 
geometry of the roadway is basically the slope and distance perpendicular to the horizontal and 
vertical geometry to each transition point in the cross section.  We define these template 
parameters in the Template Library and the data is stored in the *.itl file.  We have created a 
VAOT Template Library where standardized templates are stored and can be used as needed 
for project specific templates in a project Template Library. Creating templates is one of the 
major changes implemented in InRoads 8.7 and later.  The process for creating templates has 
changed dramatically; it is now much more graphical and all inclusive.  Template components 
and end condition components replace previous forms of modeling transverse geometry. 

InRoads help documentation contains in-depth explanations describing Template Point and 
Template Components.  Basically components are a series of points that are connected.  Each 
point in the component defines a transition or potential transition in the Template.   Points 
(formally know as Transition Control points) are used to define longitudinal breakline features in 
a surface model (DTM).   There are many ways to control points in a Template; we will go over 
the common point constraints i.e. horizontal, vertical and slope there are several others covered 
in the InRoads help documentation.    

End condition components are components that ultimately seek a target.  Often the target is 
original ground or the active surface but there are several other target types available.  Multiple 
End conditions components can be attached to a point and defined to seek for different 
parameters such as slope, once a target is found the end conditions for that point are resolved.  
End condition priorities are assigned to control the order of end condition target analysis.  If the 
first end condition fails, the second will seek if it fails, the third will seek and so on. 

7.1. THE VAOT STANDARD TEMPLATE LIBRARY 

A VAOT standard template library has been created.  This library contains predefined 
components and component assemblies that are saved as templates in the library.  Standard 
Templates can be copied to your projects template library.  These templates can then be edited 
or used to assemble your design cross sectional template.  The standard template library also 
contains a predefined point name list where point names are assigned style symbology.  

7.1.1. Starting a Project Template Library  

Section 3 of this manual covered the creation of a new blank template library and saving the 
library file to the project folder as well as adding it to the project file.  This section will cover the 
process for migrating standard templates into the project library file. 

a) Select Modeler > Create Template.  The create template dialog opens up.  Your project 
specific template library file should be displayed in the top left corner.  If you double click 
on it only a point list template will display. 

b) From the create template dialog Select Tools > Template Library organizer > Two 
windows display in the organizer dialog the left is your library to the right is the source 
library.  Click the […] button to select the VAOT standard template library.   

a. T:\CADD\Workspace\Projects\English\InRoads\template\VT_TempLib.itl 
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c) Browse to and open the VT_TemplateLib.itl, Double click on the folders in the organizer 
to expand the list.  

d) Using the right mouse button click 
and drag Point Name List from 
the right side to the left side drop it 
on the left side Point Name list.  
This will copy all point names from 
the standard library to the project 
library. 

e) Using the right mouse button click and drop the Components folder, then End 
Conditions folder to the left side (Drop it on the file name).  

f) Click the OK button and Yes to save the project template 
library to file. 

g) You now have the basic building block to create a project 
specific template.   

The Standard Template Library contains several folders with per assembled templates but 
they will require edits to fit your project.  For this lesson we will create a template from new 
components and predefined simple components.  In order to effectively use the predefined 
templates you should understand components from the ground up.  The predefined 
templates can vary in complexity; changing one parameter will/can affect other points in the 
template. 

7.2. CREATE COMPONENT TEMPLATES 

Good Template management is essential to setting up a well defined project design.  The 
template library we have up to this point contains two folders one for Components and one for 
End Conditions.  We will be defining templates to be used on VT Route 14 just as with the 
geometry we will name our templates according to there route and a description of that they do 
as well as put them all in a folder name VT Route 14.  

7.2.1. Creating New Template and Template Folders 

Open the Create Template dialog.  Open the project template 
library file (if not already open).   

a) Right click over the file name select the new option then 
select the folder option.  Name the folder accordingly e.g. VT Route 14. 

b) Right click over the folder previously create i.e. VT Route 14 select new > Template.  
Name the template accordingly e.g. VT14mainline. 

You now have a project roadway specify folder and one template designated as the mainline 
template for your project roadway design.  As the design grows you will likely have several 
templates for each roadway.  Each different template will be designed to create typical cross 
section conditions in your design i.e. templates with sidewalk without sidewalk, with guardrail 
without guardrail, bridge templates etc.  

7.2.2. Adding a Simple Component 

Although there are template components available in the template library you should know how 
to create and edit components.  In order to fully understand components we will create some 
basic components and edit the points. 
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From the Create Template Library dialog double click on the new empty template.  This will 
display the template editor window with a grid.  The active temple is shown with a RED outline 
in the template library list window. 

 

a) Select Tools > Options set the Point Seed Name to PAVE_1  

b) Toggle ON the Apply Affixes option. > set the step values to 1.00 (this is like a grid lock)  

c) Right Click in the template editor window > Click Add New Component > Simple. 

d) At the bottom of the Create Template dialog the Current Component options will display. 

• Name of the component > Pavement. 

• Style > Select SURFACE_TYPE 3 

• Slope > -2.00% 

• Thickness set to > 0.5 feet 

• Width set to > 11 feet  

e) You should now see a Pavement component attached to your cursor when you navigate 
around the editor window.  Right Click in the window > in the short cut menu select or 
toggle ON the mirror option. 

f) You now have a left and right side Pavement component attached to your cursor. 

g) Zoom in to the center of the editor window using the mouse wheel or the navigation tools 
in the bottom left corner of the editor window.  Place you cursor at the 0,0 origin 
(Magenta Square) and click to place the components  

h) Use the Fit tool at the bottom left corner of the editor window. 

i) The two components can be merged to be one component.  Right Click over the line 
separating the two components i.e. the line between point PAVE_1 and PAVE_11.  
Select the Merge Components command. 

j) Repeat the steps above with the following changes.  

• Point Seed Name set to SHOULDER_1 

• Slope > -6.00% 

• Width set to 3 feet 
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k) Merge the new components with the pavement component so we have one pavement 
component.  Notice that points merge automatically in this situation. 

7.2.3. Editing Component Points 

We now have a component shape that defines a standard (2) lane roadway with 11’-0” wide 
traveled way lanes @ -2% banking and 3’-0” shoulders @ -6% banking.  We still must edit the 
point names and symbology so that things display and work properly.  The point names were all 
created automatically from the point seed but we will edit them.  Also the symbology was all set 
the same so we will change each point’s symbology.  Double clicking on a point initiates the 
Point Properties dialog. 

a) Double Click on the 0,0 point (PAVE_1) this is the point that will follow the horizontal and 
vertical alignment in the corridor definition.  Change the name of this point to ORGIN.  
The pull down will list all point in the Point Name List.  Points selected from the point list 
have pre set styles assigned.  You will need to type in the L_ and R_ prefixes as shown 
in the image below for this example exercise.  Names can be typed in but Styles must be 
selected from the pull down list. 

b) Rename all points and assign Styles to the points as shown below.  Point Names and 
Styles are set in the Point Properties dialog box, Click the Apply button after editing 
each point. 

 

Left Prefix Right Prefix Point Name Surface Feature Style 
n/a n/a ORGIN ROAD_CENTERLINE 
L_ R_ LANE ROAD_LANE 
L_ R_ SHOULDER ROAD_SHOULDER 
L_ R_ SSF SSF_SUBBASE 

The Point Properties dialog can also be used to change the dimensions of the component.  The 
constraints section of this dialog is where points are assigned location relative to other points or 
specified values.  The InRoads help covers in-depth the constraint types.  The Simple 
component we create uses Horizontal, Vertical and Slope constraints. 

Example: the Point R_LANE has both a Slope 
constraint and a Horizontal constraint.  
Constraint 1 sets the point at -2.00% slope from 
the point ORGIN.  Constraint 2 sets the point 11 
feet right of the point ORGIN. (- values are left; + 
values are to the right). 
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constraint that says it must be 0.0 
 

Point R_SSF: Constraint 1 sets this point at 0.5 
feet below point R_LANE while Constraint 2 sets 
the point horizontally 0.0 feet from point R_LANE.  

If you move point R_LANE to have a horizontal 
constraint of 12 feet to the right of the point 
ORGIN, point R_SSF will also move retaining its horizontal 
feet from the R_LANE.  Give this a try change the constraints on points to see what affect it has
on other points.   

!! NOTE: The Template editor has UNDO (edit undo or Ctrl +z) capabilities. 

7.2.4. Define Alternate Surface 

The main function of a Template inevitably is to be added to a corridor definition and used to 
create DTM surface models.  All points in the top level of components are automatically used in 
creating the primary surface model.  Often we need to have surface models created from 
subsurface features.  Alternate layers are defined using the Point Properties Dialog. 

a) Double click on a point that will be included in the subsurface or alternate surface.  In our 
example template SSF points will be defined as the bottom of pavement DTM. 

b) Under Surface Feature Style toggle on the Alternate Surface option > Type in the name 
of the alternate surface e.g. PAVEBOTTOM. 

c) For each of the points in our template that represent the bottom of pavement, toggle on 
the alternate surface option and set the name to PAVEBOTTOM. 

d) We are unrestricted in the number of alternate surfaces we can use however a single 
point can only be assigned to one alternate surface.  Alternate surface feature points 
cannot break the standard triangulation rules i.e. no vertical surfaces.  

7.2.5. Constrained Components 

Constrained Components consist of points that are all 
constrained to the previous point placed.  Each point is placed 
to form the component shape.  This component type is useful 
for constructing curbs, sidewalks, etc. after creating these 
components the constraints can be edited to any available 
constraint combination. 

a) Create a new Template.  This can be done with a right 
click on a template folder select new template. 

b) Name this new template “Curb” you should get a new blank template with a magenta 
square at the 0,0 point.  This is where the curb template will attach to a pavement 
shoulder point. 

c) In the Create Template dialog select Tools > Dynamic 
Settings > set the dynamic settings as shown. 

a. Steps @ 0.1 ft this is a snap like grid in the template 
editor window.  

b. Point Name to CURB_1 

c. Point Style to ROAD_CURB_CONCRETE 

d. Apply Affixes OFF and do not close this dialog, but move it to the side of your 
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screen we will be entering numbers in the key-in field to the bottom right. 

d)  Right Click in the template editor window select Add New Component > Constrained. 

e) Place a point at 0,0 in the template editor window (xy=0,0).  The point is displayed and 
you are ready to place the next point. 

f) Set the Key-in Type to vs= for Vertical Slope this means you enter in a value for the 
vertical and a value for the slope.  Perform the following Key-in operations to draw the 
curb component.  The enter button will place the point at the specified Key-in locations. 

Key-in Type Key-in 

vs= {vertical slope} 7”,6/1 

hs= {horizontal slope} 6”,0 

dl= {delta from last point} 0,-18” 

dl= {delta from last point} -9”,0 

g) There are other key-in types; InRoads help covers these and much more on using the 
dynamic dialog box. 

h) All the points were placed using the point seed name set in the dynamic dialog box as 
well as the point style.  Rename the points as shown below.  

i) While in the point properties dialog view and verify that the constraints are set as you 
expected.  All points should be located 
horizontally and vertically to the previous 
point; all tied back to the first point placed in 
this case the CURB_CONC point.  

j) To test that all points are tied back to the 
CURB_CONC point, Right Click over it and 
choose move, as you can see all points 
move with this point.  Right Click to cancel 
the move command. 

7.2.6. End Condition Components 

End Condition Components are linear components that target a surface, or some other specified 
parameter such as an alignment.  End conditions replace Decision tables from previous 
versions of InRoads software.  Using the template creation dialog we can use the test option to 
graphically analyze end condition results for the various parameters. 

End conditions can be used to generate cut and/or fill slopes off the backbone components.  We 
will create 6 different end condition components 3 for a fill situation and 3 for a cut situation.  
These end condition components will then be inserted into our VT14mainline template. 

a) Right Click on the template folder you are working in and 
create a new template named Cut/Fill set this template 
active and create the end conditions as directed below. 

b) Tune on the dynamic settings dialog > set the point name 
to ORIGIN > set the point style to ROAD_CUT 
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hat 

IN 

UT_25 and set the name to 

c) Right click in the template editor window select Add New Component > End Condition 

d) Below the editor window; Name this component CUT 25 > Style to ROAD_CUT 

e) Set the Target Type to Surface > set the surface to be <Active> 

f) Click on the 0,0 point in the editor window to place the ORIGIN point, OR key-in xy=0,0 

g) In the dynamic setting dialog. Set point name to DITCH > Style to ROAD_DITCH; note if 
you select the point name from the list the style is set automatically 

h) Key-in hs=8,-0.25 [enter] (8 ft to the right @ -25% slope) 

i) Set point name to CUT_25 

j) Key-in hs=20,0.25 [enter] (20 ft to the right @ 25% slope) 

k) Right Click > Finish 

l) Using the edit point properties dialog box, toggle the Check for 
Interception option OFF for the point DITCH.  This is to insure t
in this cut situation the DITCH point will be placed because the 
end condition will not seed the surface between the point ORIG
and the point DITCH.  

m) Using the edit point properties dialog box, toggle ON 
the Feature Name Override option for the point C
ROAD_CUT.  All the cut end conditions should have the same feature name i.e. 
ROAD_CUT as apposed to the actual point name of CUT_25. 

n) Use the Test button at the bottom right of the editor window to test this CUT end 
condition, notice that when the surface crosses the first segment it does not terminate 
the component, this is where the Check for intercept toggle effected the segment. 

The above process is a method for creating a standard 1:4 cut with ditch end condition.  This 
method can be repeated to create a 1:3 cut with ditch end condition and a 1:2 cut with ditch end 
condition or any slope required by the design.  It is a standard practice to create all these cut 
end conditions in the same template as 
well as the fill end conditions.   

Create the above mentioned cut with 
ditch end conditions then create the fill 
end conditions.  Fill end conditions will 
start at the point ORIGIN then have one 
segment that ends with the points 
FILL_25, FILL_33, FILL_50 as shown. 
Remember to set the component names 
and styles accordingly. 

Tip: If you Right Click over a point when 
selecting new end condition the end 
condition will automatically attach to this 
point as the start location.  If you when 
click directly on a point it will 
automatically merge the points.  You 
should not have points on top of points 
this will cause tolerance issues. 



VAOT InRoads Fundamentals Manual----------------------------------------------------------------------------------------------------------------------2007 
 

VAOT_IFM Page 46 2/20/2007 

Once the cut and fill end conditions are created set the feature name override for all the cut end 
points to ROAD_CUT (as explained above) and set all the fill end point to have an override of 
ROAD_FILL.  With all these end conditions defined we then assign priority levels to each one.  

Generally the 1:4 cut and fill are more preferred than the steeper slopes.  For this reason we will 
set the priority accordingly where the 1:4 fill is tested first, the 1:4 cut second, the 1:3 fill third, 
the 1;3 cut forth and so on.  Priority settings are shown in component properties dialog; this can 
be access by double clicking on a component.  Priority can be set when placing the 
components; by editing component properties or they can be set when using the [Test…] option.  

7.2.7. Test End Conditions 

The test option button is located to the bottom right of the template editor window.  This option 
brings up its own Test End Condition dialog where you have several testing options.  To test our 
Cut/Fill end conditions we will use the <Active>-Surface option in the Available Targets window.  
In the Use Surface Slope window we can set a slope to the targets surface.  Clicking the draw 
button allows you to dynamically move the surface elevation line with your cursor and view the 
end condition for each situation.  When attempting to test the template you may get a message 
alerting end condition priority conflicts > click OK we will Check Priorities and edit them in the 
testing dialog. 

a) Enter the TEST dialog by clicking the [Test…] button on the Create Template dialog 

b) OK > through the conflicts warning if you get it. If not we can still edit the Priorities 
settings in the testing dialog. 

c) Click the Priorities button, if you have more then one point with 
end conditions you can choose the point you would like to check 
end conditions for.  In the Cut/Fill template all end conditions are 
attached to the point ORIGIN.  

d) The fix priority dialog allows you to enter priority values 1 or the 
lowest number being the highest priority or best solution.  End 
condition components will highlight in the test window as you 
place your cursors in the priority window fields. 

e) After priorities are set, click OK and close. Now use the Test > Draw button to view the 
end conditions interactively. 

Note:  Each design may require different End Condition priorities.  This example sets the 1:4 cut 
with ditch end condition as the first priority, in some cases the 1:4 fill may be the most desirable 
solution therefore it would get the first priority setting. 

7.2.8. Infinite End Conditions 

When creating end conditions the constraints on the CUT and FILL points were set by default 
according to their placement.  In the workflow above we used key-in commands to precisely 
place points resulting in constraints that reflect position.  End condition points are by default 
place with horizontal and slope constraints regardless of how you placed the point.  Placing the 
point in the proper position initially will set the constraints properly without edits.   

After testing the end conditions it is apparent if the surface extends beyond a horizontal 
constraint the end condition fails and moves on to the next according to priority settings.  The 
intent is, if a 1:4 slope cannot connect with the target surface (og) within the horizontal 
constraint distance, move on to an alternate slope.  This process works until we get to the last 
end condition in the set.  In our set, when a 1:2 slope does not connect with the target, there are 
no more options, resulting in no end condition solution.    
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In most end condition component sets we define points having an infinite 
horizontal reach.  This is done as a last attempt to intercept with the 
target surface regardless of its distance.  Generally the last priority CUT 
and FILL end conditions will be set to “End Condition is Infinite”.  In our 
example Cut/Fill end condition set the CUT_50 and FILL_50 are the last 
priority and should be set to “End Condition is Infinite”. 

End condition points can be edited by double clicking on the point to get the point properties 
dialog box.  Make sure to click the apply button after making any changes to points in the point 
properties dialog. 

When testing the end condition now, you will see if you move you target surface line to the top 
of the window the CUT_50 end condition will always intercept.  Likewise if you move the target 
surface to the bottom of the window the FILL_50 end condition will always intercept. 

7.3. ASSEMBLE TEMPLATE FROM COMPONENTS 

In the previous section we created components that can be combined to create a complete 
design cross section template.  We created the pavement component, created a curb 
component, and end condition components.  The components created can be used and edited 
as needed and can be used in combination with other components in the template library.  The 
VAOT standard template library contains several other predefined components.  In this section 
we will combine components to create a typical design cross section template.  As we will see 
after constructing a template from components it may be necessary to edit individual 
components to fit the design.  

a) Open the Template Library: Modeler > Create Template… 

b) Double click the template library in the left window listing to expand the library folders 

c) Double click on the folder where you have the template and double click 
(to set active) the template you are going to edit e.g VT14mainline.  The 
active template is the one displayed in the editor window, the red outline 
on the template bullet icon indicates the active template in the list window. 

d) This template contains a pavement backbone component that was created in a previous 
section of this manual.  We will be adding to this template 

e) Turn on the Dynamic settings dialog and toggle on the Apply Affixes option.  This will 
prefix new components with the L_ or R_ depending on the location 

f) Click once on the curb template notice that the curb is displayed in the preview window, 
with a cyan marker indicating the insertion point, this point can be move by clicking on 
points in the preview window.  In this case the insertion point as shown here is correct.  
Click and drag the curb to the template editor window  

g) When your cursor is over the editor window you will see the 
curb component.  Right click to activate the context sensitive 
short cut menu > toggle ON the mirror option.  Now you 
should see two curb components that dynamically mirror 
each other. 

h) Place the cursor over the point R_SHOULDER when it 
highlights white indicating a snap to the point > click to place 
the curb component. 
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i) Click once on the EdgeBuffer template located in the components folder that was copied 
from the VAOT Template library in a previous section of this manual > drag this template 
to the point R_CURB_BAK 

j) Click once on the Cut/Fill template > drag this template to the point R_EDGE_BUF that 
was part of the EdgeBuffer template. 

k) This template is almost complete; you can use the test option to test the end conditions.  
You can use the check priorities button in the test dialog to change the priorities if 
required. 

7.3.1. Vector-Offset Constraint  

This template now represents a design typical section template.  If you 
zoom in on a curb section where the curb meets the pavement you will 
see where the pavement overlaps the curb.  We should edit the pavement 
component points to match the face of the curb.  This can be done using a 
vector-Offset constraint.  To setup a Vector-Offset we will identify two 
points in the template then enter a value for the offset.  In this case the two points will be points 
that form the face of curb.  We want the pavement to follow the face of curb so the offset in this 
instance will be 0.00 feet. 

a) Edit the properties of the point R_SSF_1 (double click on a point to activate the edit 
properties dialog) 

b) The constraints are set to one horizontal and one vertical > set the Horizontal constraint 
to Vector-Offset > Set Parent 1: to R_CURB_TOP and Parent 
2: to R_CURB_SSF, and the Value to 0.00.  You can use the 
target buttons to select parent points. 

c) Click The Apply button. > Close 

d) Repeat this process for the left side point L_SSF_1 that overlaps with the concrete curb 
component. 

The pavement component point R_SSF_1 now is positioned at a 0.00 FT offset from the vector 
formed by the points R_CURB_TOP and R_CURB_SSF.  This slope on the pavement edge 
could have been done using other constraint types i.e. horizontal, vertical or slope.  In this case 
it seems appropriate to set the pavement edge using the curb face. 
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7.4. EDIT AND REVIEW TEMPLATE 

At this stage of the process we have a usable typical section template.  There are several other 
methods that deserve mentioning that can be used to edit and review template points and 
components.  In the Create Template dialog we have several display options.  In the Template 
Library window to the right of the create template dialog we have the Library tab and the Active 
Template tab.  There is also a process for placing a template in the active design file with 
dimensions and slopes annotated.  

7.4.1. Display Options 

At the top of the Create Template Dialog the Display Options can be very useful.  The first and 
most common, is Components.  This is the mode we have been using up to this point.   

The Constraints option graphically shows symbology 
that indicates how each point is constrained.  A blue 
arrow pointing to CURB_TOP from CURB_CONC 
indicates that CURB_TOP is constrained to 
CURB_CONC.  In this case the + symbology on the 
blue arrow indicates the constraint is both horizontal 
and vertical.  Check out the other points and 
familiarize yourself with the symbology used to 
display constraints. 

7.4.2. Active Template Tab 

To the side of the Create Template dialog at the bottom of Template Library window the Active 
Template TAB allows you to view point and component information in the active template.  In 
this window you will find folders for template points, components and Display Rules.  When you 
select the points in the point folder the point highlights in the editor window and properties are 
listed in the window.  Double clicking on points in this window will also activate the point 
properties dialog where edits can be made. 
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7.4.3. Graphical Display Options 

In the Create Template Library dialog you have the ability to generate a graphical display that 
can be place and use in your design file.   

a) From the Create Template Library dialog, Template Library window > Right click on the 
template you are generating graphics for e.g. VT14mainline. 

b) Select at the bottom of the short cut menu the Display option.  This will activate the 
Display Template dialog.  

c) Notice the end condition components are dotted.  Using your mouse cursor click ON all 
the end condition components that you require in your display.  When you select them 
they will turn to solid lines. 

d) Click the Apply button and data point in your design file to indicate the location for the 
Template Display. 

 

The display of VT14mainline above is the result of the Template Display command.  Minor edits 
were made to clean up the extra dimensions and slopes associated with the CONCRETE CURB 
components.  Note: shoulder slopes when curbing is used will often do not change from the 
traveled way slopes, maintaining a constant slope on narrow shoulders is common.  In this 
example the shoulder brakes to a 6% transverse slope but could easily be changed to 2% if and 
when applicable. 
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SECTION 8 – ROADWAY DESIGNER 

 
8. INTRODUCTION 

The roadway designer is an interactive command/process that combines horizontal and vertical 
geometry with transverse geometry defined in the templates.  The process involves defining 
corridors with the required geometry i.e. horizontal, vertical and transverse, then uses a variety 
of controls, exceptions, references, transitions, modified templates and super elevation 
definitions, to create 3 Dimensional models of the roadway design.  The roadway designer is 
intended to minimize the amount of edits made directly to the DTM.   

InRoads Help, provides in-depth explanations on every aspect of the Roadway Designer.  This 
section of the manual is intended to provide a standard work flow as a template for using the 
Roadway Designer command and its processes.  We will create a proposed surface model 
using basic tools available in the modeler.  The modeler has many advanced capabilities for 
controlling surface models; see InRoads Help documentation for more information on these 
capabilities. 

Section 3 of this manual covers creating, saving and loading Roadway designer .ird files.  

8.1. DEFINE A ROADWAY CORRIDOR 

Each new roadway or other type of surface involves naming and creating a corridor based on an 
alignment or feature.  One roadway designer file or .ird can contain many corridor definitions.  
Typically we will use the corridors to define roadways but they can define channels or ditches or 
any other surface that is based on a linear control. 

a) From the InRoads main menu select > Modeler > Roadway Designer, at this point you 
should see the Roadway Designer dialog with 3 empty view windows.  This dialog and 
all the windows are resizable using you mouse cursor. 

b) Select > Corridor > Corridor Manager command  or the  button 

c)  In the Manage Corridor dialog type the name of the corridor e.g. RT14prop.  Note: the 
corridor name will also be the name of the DTM created by this corridor.   

d) Set the Type: to 
Alignment  

e) Select your design 
Horizontal Alignment 
e.g. VT14prop_1 

f) Select your Vertical 
Alignment e.g. v1  

g) PI Rounding for 
roadways will typically be 0.00 

h) Station range can be toggled off to allow the corridor to apply to the entire alignment 
from POB to POE of the vertical geometry. 

i) Use the ADD button to add or create this corridor; Click > Close. 
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We now have a new corridor defined in the roadway modeler.  Notice the other button on the 
right hand side of the corridor manager we can select and change corridor parameters.  The 
copy or copy from command can copy a corridor in the current modeler or from an .ird file in 
another project. 

8.1.1. Roadway Designer Options 

Located on the Roadway Designer main menu > Tools > Options 

This dialog offers many useful options including Critical Sections (set ON by default) to use 
during the design and Display Options.  Over the next few sections we will be setting up some 
of the Display types that can be toggled ON or OFF.  We will be working with Reference 
Graphics once we set them up we can toggle them display on or off as desired the same is true 
for the Transition Graphics markers, there can be many transition markers if they get in the 
way toggle them off when you do not need them. 

8.2. ADD TEMPLATE DROPS TO CORRIDOR 

Template drops are where the templates from the template library are applied to the horizontal 
and vertical geometry assigned to the corridor.  Templates are copied not referenced from the 
template library to the roadway modeler and assigned to station ranges.  It is possible to drop 
different templates at defined station ranges to achieve changes in the roadway design.  As an 
example one section of roadway may be a two lane typical that transitions into a bridge then 
back to a two lane typical.   

Using point controls and parametric labels one template can be setup to change depending on 
parameters defined in the roadway modeler.  This method can reduce the number of different 
templates used.  In this design we will use the template we created in the previous section as 
well as one directly from the VAOT standard library.  We will then apply simple point controls 
and define parametric labels to change the transverse geometry of the roadway design.  

a) From the Roadway Designer Select > Corridor > Template Drops 

b) From the Template Drops dialog select the 
corridor e.g. RT14prop  

c) The station is the first station that this template 
will be applied e.g. STA 500+25.00 is the 
beginning of the vertical alignment.  The target 
button to the right of this field will allow you to 
graphically select template drop locations on 
the screen.  Hold down the [Ctrl] when 
selecting the target to get to the active 
MicroStation design view. 

d) Interval: is the spacing that templates will be 
dropped, set this at a value appropriate for 
your project e.g. if you plan on displaying 
cross sections at 25 foot intervals your Interval value should be evenly divisible into 25’ 
this will make your cross sections more accurate.  In this case we will use a 5 Foot 
Interval. 

e) In the Library Templates window expand the library folders and select your design 
template e.g. VT14mainline. 
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f) Click the Add button  

g) Click on the […] button to the right of the 
Library Template window.  We will browse 
directly to the VAOT standard template library 
to select the next template.  Browse to 
VT_TempLib.itl and OPEN. (location shown 
previously) 

h) Double click on the library to expand and 
navigate down to the DesignTYPICAL folder 
and select VT_Bridge/TYP 

i) In this case the bridge begins at station 
506+35.00 and will be dropped at the 5’ 
interval 

j) Click the Add button to add to the list of template drops 

k) Next select by clicking the first template drop in the list in this case that is STA 
500+25.00 – VT14mainline.   

l) Change the Station value from 500+25.00 to 507+40.00 then use the Copy Button to 
add this as a new template drop in the list of drops. 

m) Click on the Close button > Use the Roadway Designer File > Save command to save 
your roadway designer file to disk. 

In this example we now have 3 template drops defined.  The blue template name is simply 
indicating that the template does not exist in the current template library.  We could, and most 
often will, have all the templates we need in our project template library but this illustrate some 
of the additional functionality of the template drop dialog. 

Note: When templates are selected and used in the roadway designer they are copied to the 
roadway designer .ird file.  These templates are not automatically synchronized with the library 
they originated from.  However if you load the library that the template originated from they can 
be synchronize using the synchronize button on the bottom of the template drop dialog.  If a 
template drop is red this is an indication that they are out of sync with the template library.  It is 
not necessary to have synchronized templates, but it is a good practice to keep the template 
library up-to-date and keep all template drops synchronized when possible. 

8.2.1. Roadway Designer Main Dialog  

• Menu Items located at the top left corner of the dialog. 

• Buttons located directly below the menu items can be used as a shortcut to access 
menu items. 

• Plan View Window: Upper right corner used to display and locate horizontal alignment 
and plan information while using the modeler. 

• Profile View Window:  Lower right corner used to display vertical alignment and profile 
information while using the modeler. 

• Cross Section View Window: Right side of the modeler, used to show template 
component and end conditions along the corridor.  The Active surface is shown as well 
as all other targets associated with your templates and referenced by the modeler. 
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8.2.2. Template Transitions 

When templates that contain points that do not match up i.e. templates contain additional points 
or points of a different name, a transition must be defined.  Notice in the example from the last 
section that 2 yellow highlights were displayed in the plan view of the Roadway Designer Dialog.  
These indicate that a transition condition exists.   

Right click over the yellow high light and 
select the edit command.  This will initiate the 
edit transition dialog.  This dialog shows a 
window with an outline of the two templates 
that are transitioning.  In the example the 
VT14mainline has points that do not connect 
e.g. the two shoulder points and the crown 
points do not match.   

You can right click over points in this dialog to 
move the view angle.  This may be required to 
see all the points that do not match up.  The 
bolded (+) indicates orphaned points.   

a) Use your mouse to drawn lines that connect the VT14mainline ORGIN point to the 
Bridge CRWN point (shown here as Dark-Blue).  Simply click on the ORGIN point then 
click on the CRWN point.  

b) Connect the Left shoulder line from VT14mainline to the bridge template (shown here 
White). 

c) Connect the Right shoulder line from VT14mainline to the bridge template (shown here 
Magenta). 

d) In this example the bold red points of the subsurface in the VT14mainline template 
would not want to be connected to the bottom of the bridge deck so we can leave them 
orphaned as required. 

e) Next click the OK button you will get the Edit 
Transition Midpoint dialog.  For more details 
using this dialog refer to the InRoads Help.  
In this example edits to this portion of the 
transition is not required. Select the OK 
button 

f) The yellow highlight should turn cyan 
indicating that edits have been made.  Right 
click over the cyan highlight and toggle off 
the check mark by enable.  This will stop the transition from happening over the entire 
length of the template drops but will transition from the last interval template drop.   

g) Repeat this process for all transitions. 

Note:  The process of editing transitions may need to be redone if you change or synchronize 
templates involved in the transition.  You should hold off transition edits until your templates are 
finished or you may need to redo them.  In this example we do not intend to transition 
VTmainline into a Bridge.  To turn off a transition, right click on the transition area and un-check 
the Enable option.  The template transition options would be more applicable for a 2 lane to 4 
lane transitions or sidewalk to no sidewalk etc. 
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8.3. TEMPLATE POINT CONTROLS 

There are several different ways to control template component points.  One very powerful 
method is point controls.  This is where we select a point that exist in the current roadway 
corridor and define instructions for what that point should do over certain station ranges.  This 
could involve horizontal, vertical or both types of controls.  We will use these types of controls 
when we define the superelevation.   

One simplified method of using point controls is to use Parametric Labels for controlling points.  
This is a predefined set of labeled point constraints that allows for point constraint modifications 
over defined station ranges.  This method can control several points of a different name as long 
as the share the same parametric label in the template.  

In the example we have been using VT14prop, we used the VT14mainline template and a 
Bridge template from the VAOT standard template library.  The VT14mainline template does not 
contain parametric labeled constraints but the Bridge template we used contains several.  We 
will use these labeled constraints to parametrically alter lane and shoulder widths of the bridge 
template to match our design.  Most of the templates and components in the VAOT Standard 
Template Library have labeled constraints. 

8.3.1. Define Parametric Labels 

a) Select from the 
roadway modeler > 
Tools > Parametric 
Constraints 

b) Select Constraint 
Label: 
L_LANE_WIDTH from 
the pull down list. 

c) Change the L_LANE_WIDTH Start Value to -11.00 ft. 

d) Change the Station Limits to the stationing where we are intending to alter the lane width 
in this example Start STA = 506+35; Stop STA = 507+40.   

e) Proceed with changing both lane width values to 11’-0” and the shoulder 
(SHLD_WIDTH) values to be 3’-0”.  Values to the left of the of the center line are (-) 
negative. 

Note:  This exercise in parametric labels was only used as an example.  In reality you should 
copy the bridge template to your project and make edits to the template to match your design 
criteria.  Parametric labels can be used for adding turning lanes or widening the shoulders 
where the design requires.  These labels can also be used to change vertical, slope or any other 
constraint value that is assigned a parametric label in the templates.  

8.3.2. Define Point Controls 

Point Controls are used to horizontally and vertically control template points.    These controls 
override all other forms of control applied by point constraints.  There are several control types 
available in the Point Controls dialog.  For more information on point controls see InRoads Help. 

In this example we will transition the right side lane after the bridge exit from one lane to two 
lanes accounting for traffic entering from the side roads.  The two lanes will merge back to one 
lane after the horizontal curve ends. 

a) From the Roadway Designer > Select Corridor > Point Controls 
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b) Point = R_LANE 

c) Mode = Horizontal 

d) Control Type = 
Alignment with the 
Horizontal Alignment 
set to VT14prop_1  

e) The lane widening will 
begin at STA 507+60 
and end at STA 
511+00 

f) The two lanes will be a 
total of 22.00 feet wide 
to the right of the 
horizontal alignment VT14prop_1 from Start to Stop. 

g) The two lanes will merge back to one starting at STA 511+00 and stopping at STA 
512+00. 

h) The start of the merge is the full 22.00 feet wide the stop point of the merge is set back 
to the 11.00 feet to the right of the horizontal alignment.  

This lane widening involves an intersection with two side roads.  The features generated by the 
modeler at the intersection will be edited or clipped out when the intersection is completed using 
feature edits or more advanced corridor definitions with surface clipping options.  For now we 
will ignore the back bone features that cross into the intersection area.   

8.4. DEFINE END CONDITION EXCEPTION 

The backbone components of a template can be considered components that are not End 
Condition Components.  End condition components are defined and created in the template to 
seek a target in our example the target is existing ground.  It is often the case where we need to 
control or override the end conditions seek function solution.  This is done using End Condition 
Exception Tools. 

Note:  To this point we have not discussed superelevation.  Superelevation banking if 
required on your project should be done prior to overriding and transitioning end conditions.  
This is because superelevation will affect the starting elevation of your end conditions therefore 
it will affect the intercept location.  In this example we explore end condition modifications 
assuming there is no superelevation in this design.  We will then in the next example define 
superelevation.  If you have superelevation in your design most of your end condition 
modifications should be done after not before using the superelevation wizard and defining 
rollover locks.  

8.4.1. Backbone Only 

The simplest of Exceptions is to eliminate the end condition entirely for a given side and station 
range.  This is done using the Override option with the Backbone only toggle on.  For this 
example we will apply the backbone only option to the area of our design where side roads 
meet our proposed roadway corridor. 

a) From the Roadway Designer Select > Corridor > End Condition Exceptions  

b) The station range will be from 507+55 to 508+52 
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c) Apply To: Right Override 

d) Toggle ON Backbone Only 

e) Click the Apply button 

8.4.2. Overrides 

Within the End Condition Exception dialog the 
Left Override and Right Override serves as a 
method for overriding current end condition solutions.  This involves locating sections of the 
corridor where the end condition solutions do not meet the design requirements.  There are a 
variety of reasons why end conditions may need to have overrides defined.  As an example one 
reason to use the override is when a stretch of roadway/corridor is in a fill situation but a mound 
or lump in the existing ground causes a small section to switch into a cut situation resulting in a 
ditch.  In this instance we can go to the station just prior to the ditch starting and use an End 
Condition Exception Override to force the fill end condition through.  This process involves 
defining the start and end station then editing a template override to solve as desired through 
the defined range. 

Example:  Cross Sections: STA 504+10 - STA 504+60 
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a) Use the end conditions example shown at STA 504+10 “FILL” to override the resultant 
ditch through STA 504+60. 

b) Set your active template drop view to STA 504+10.  This can be done using the < > 
arrow buttons below the cross section view window or by typing in the station value and 
clicking the TAB key.  The yellow line shown on the plan and elevation views indicate the 
active template drop view location. 

c) Select Corridor > End Condition Exceptions 

d) The dialog should show the active template drop as the start station, if not set Station 
Range Start value to STA 504+10 for this example. 

e) Set the Stop Station Range value to STA 504+60 

f) The Apply To option will be set to “Left Override” in this example as shown in the cross 
section set above. 

g) Click the Add button > Then the Edit 
Button  

h) A template editor window appears.  From 
this dialog notice only the left side end 
condition is shown solid indicating edits 
can only be made to this component or 
you could construct or insert new end 
conditions 

i) Double click on the L_FILL_25 point to edit the point properties 

j) Set the End Condition is Infinite toggle ON 

k) Set the Horizontal and Vertical Constraints to 
the design criteria, in this example the 
Horizontal is set to -5’ from the 
L_EDGE_BUF point.  The slope is set to 1:4 
from the edge buffer point.  

l) Click the Apply > Close > OK; this end condition exception is now completed.  As you 
define exceptions they will be listed in the End Condition Exceptions dialog.  Close the 
End Condition Exceptions dialog.  

This is a new concept as far as editing the end conditions or side slopes in your design.  Prior to 
InRoads 8.7 these type edits were made directly to the surface model features.  The edit 
features in cross section command was removed and functionality such as this tool replace it. 
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8.4.3. Transitions 

When end condition solutions change, such as from a 1:4 fill to a 1:2 fill, a smooth transition 
over a defined station range may be required.  This transition will be a linear slope change over 
a defined station range.   

Slope Transition Example:  Cross Sections: STA 513+95 – STA 516+65 

a) From the Roadway 
Designer Select > 
Corridor > End 
Condition Exceptions 

b) Set the station range 
accordingly in this 
example Start at STA 
513+95, End at STA 
516+65. 

c) Apply To: Left 
Transition as shown in 
the cross section. 

d) Click the Add button > 
Then the Edit button 

e) An edit transition dialog 
appears.  In this dialog 
we see both the 1:4 and 
1:2 end condition components represented in red dashed lines.   

f) Using your mouse cursor click on the GREEN + symbols to connect them.  The line you 
created represents the slope transition portion of the L_FILL point. 

g) Click the OK, this dialog lets you view the transition, notice by moving the slider button 
you can view the slope component changing from a 1:4 to a 1:2 this is a symbolic 
representation.  

h) Click OK and Close, now in the plan view you will see a dark blue marker representing a 
defined transition range.  
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Shown above is the cross section set from STA 513+95 – STA 516+65 the same range as prior 
to the transition override but now the slopes transition linear from 1:4 to 1:2.  The precision 
value for slopes has been bumped to 1/10,000 to help show the transition. 

NOTE:  We have discussed procedures for modifying end conditions.  Later on we will go over a 
procedure for defining superelevation for the roadway.  Superelevation banking will effect the 
elevation of the shoulders as well as the starting point for end conditions.  Do not get overly 
ambitious with end condition modifications until backbone point elevations are well defined.   

8.5. DISPLAY REFERENCE IN DESIGNER 

This tool provides a method for viewing alignment and or feature data in the modeler plan and 
cross section view windows.  In the example we have been using we will display several 
features from the original ground DTM. 

8.5.1. Display References by Feature 

a) From the Roadway Designer Select > Corridor > Display 
References  

b) Toggle ON the Features option > Select the proper 
surface for your feature for this example the surface is 
x86e055og the survey original ground DTM.   

c) In the feature list pull down select the feature you are displaying as a reference.  If you 
do not know the feature name use the target button to select the feature on the screen.  
In this example we need to display a drainage pipe crossing the road.  The name of the 
feature is P365.  The alpha code P is used by the survey section to pick up drainage 
pipe inverts the numbering (365) is due to incremental name changes. 

d) Click the Add button.  The bottom of the dialog list all current display references 

8.5.2. Display References by Filter 

a) From the Roadway Designer Select > Corridor > Display 
References  

b) Toggle ON the Filter option > Select a filter from the list 
of filters, for this example we will use the x_ROAD filter.  
This filter will display existing roadway features picked 
up by the survey. 

c) Click the Add button 

d) Select the X_DRIVES filter and click the Add button.  This filter will display all existing 
drives picked up by the survey. 

8.5.3. Display Reference Graphics Options 

Once you define Display references they appear as pink lines in the modeler plan view and 
point markers in the cross section view.  To turn off the reference graphic or hide them you can 
use the Tool > Options dialog > Toggle OFF or ON the Reference Graphics. 
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8.6. DEFINE SUPER ELEVATION 

Super elevation is stored in the InRoads Roadway Designer IRD file.  The process for setting up 
super elevation is done using the Roadway Designer, super elevation wizard.  The wizard has 
several methods normally VAOT uses the table method then selects one of the corresponding 
AASHTO tables.  For legacy projects there is an importsuper elevation command that will 
translate super elevation geometry to corridor superelevation control lines.   

8.6.1. Range Point Name Check 

Super elevation is stored in the roadway designer as point controls of the type superelevation.  
For this reason point names in templates that are used as superelevation control points should 
be named constantly.  The example corridor we have defined point names that do not remain 
consistent.  

In super elevation we will use the Center Line of the road for the Crown Point, the left and right 
lane will be the left and right Range points.  Additionally the left and right shoulder points will be 
used for the rollover locks.  We will check and edit these points to have consistent names. 

 

The image above shows point names used for the VT_Bridge template.  The image below 
shows the point names used for the VTmainline template.  If we use the bridge template as the 
standard since it came directly from the VAOT Template Library notice the center line of the 
road should be named CRWN and the left and right shoulder should be L_SHLD and R_SHLD.  
The left and right lane point names are OK. 

 

8.6.2. Edit and Synchronize Templates 

a) From the InRoads main menu select Modeler > Create Templates 

b) Select in the template library the template we are going to edit e.g. VT14mainline 

c) Double click on the ORGIN point and rename by selecting CRWN from the point name 
pull down list. 

d) Double Click on the L_SHOULDER point and replace SHOULDER with SHLD you will 
need to key the new name in. >> Repeated for the R_SHOULDER point. 

e) Save the template library: File > Save > then Close 

f) Open the Roadway designer > Select the Template Drop 
command.  Notice that VT14mainline is displayed in red.  
This means it is out of sync with the template library. 

g) Select the Red Template drops with your pointer > Click 
the Synchronize with Library button.  
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h) These templates in the Roadway Modeler now match your project template library.   

Note:  Back in Section 8.2.2 Template Transitions it was mentioned that when the 
“Synchronized with Library” command is used the template transitions may reset.  In this 
example this tool was used and the transitions must be redone, refer back to Section 8.2.2.  If 
the templates were edited directly in the Roadway Designer the transitions will not completely 
reset but you will still need to edit and reconnect the points, in this example it seems reasonable 
to keep the library up-to-date and use the synchronize tool. 

8.6.3. Use Superelevation Wizard 

Once you have template drops defined it is possible to define superelevation.  Superelevation 
will use horizontal control lines to control range points and rollover points.  Changes to your 
design such as template point names or geometry stationing will alter superelevation.  Any such 
changes to the design will require reworking or redefining superelevation. 

a) From the roadway modeler 
Select > Superelevation > 
Table… 

b) The default table loaded here 
is the (emax=8%_Vd =70mph) 
table or 08_70.sup file > Click 
the […] browse button and 
select the appropriate table for 
your curve. 
 
Super Tables are located in the 
Workspace\Project\English\InRoads\super\ {folder}.  There are several versions currently 
the VAOT standard uses AASHTO 2001 but the AASHTO 2004 is very close in value, 
and widely considered an improved method. 
 
For this design example curve 1 and curve 3 will be designed for (55mph with emax=8%) 
while curve 2 will be designed for (35mph with emax=6%).   

c) Under General Superelevation Data in the Table Wizard change the loaded table to the 
08_55.sup file using the […] browse button to the right of the Table field. Select and 
open the appropriate file.  This example will use the AASHTO 2004 08_55.sup file 

d) Use the mouse cursor with the Ctrl key depressed to select both curve 1 and 3 from the 
curve set list. 

e) Click > Load Values From Table button, this will update the curve set list to show the 
table being used is the 08_55.sup 

f) Browse to and select the AASHTO 2004 06_35.sup file 

g) Use the mouse cursor to select curve 2 from the curve set list 

h) Click the > Load Values From Table button 

i) The Curve Set list should 
indicate that the correct super 
tables are being used for each 
curve as the design requires.  

j) Click the Next> button on the bottom of the Table Wizard, this will bring you to the 
Superelevation Section Definitions dialog. 
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k) Use the Add… button to start your section definition 

l) The section name by default will be Section 1 

m) For the Crown Point select > CRWN point.  This can be 
done using the pull down list or by using the target 
button to select the point on the screen from the 
modeler cross section view window. 

n) Set the Left Range Point to L_LANE 

o) Set the Right Range Point to R_LANE, the pivot direction is OK at From Crown Point 
and this is a 2 lane design. Click OK 

p) From the Superelevation Section Definitions dialog review the definitions setting.  The 
start stop stations are indicated as well as the runoff lengths and more. 

q) Click the Next> button, the Superelevation Controls dialog allows you to review the 
vertical control line data, what they will be named and what point and slopes are 
involved.  The Station rounding has been set at 1 foot by default but can be changed if 
required. 

r) Click the Finish button; if you have Overlaps you will get the Fix Overlap dialog for 
more information on this dialog refer to InRoads Help.  Our overlap edits will be 
corrected later in the dynamic super display window (Close this dialog) 

The main super control is now defined; to view the superelevation click on Display 
Superelevation button on the bottom right corner of the roadway designer dialog.  The Process 
All button will make the display of super in this window display completely. 
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8.6.4. Edit Superelevation Control  

 

From the display superelevation option of the roadway modeler we can view different aspects of 
the super elevation.  Each window has a purpose.  The yellow line indicator in each window 
shows your current cross section template drop location. 

Super Display View Description and usage of view windows 

TOP LEFT Plan view with color coded banking Blue = 8%, Orange = 6%, White 
= 0% and a gradient range in-between these colors 

BOTTOM LEFT Cross Section view of corridor backbone with color that match the 
plan view 

TOP RIGHT Color coded Profile view of the corridor 

BOTTOM RIGHT 
Banking Diagram Control line view; from this view edits to the 
banking can be made.  Edits are done using a variety of tools we will 
use several of these in modifying the example design 

In the example design we have Runoff overlaps in the superelevation control lines for all 3 
curves.  This is typical and we can easily edit the overlaps from the Banking Diagram Control 
line view.  Additionally we have overlapping full super start and stop stations for curve 1.  We 
will edit and correct all these errors while graphically viewing the changes in the roadway 
designer Display Superelevation mode. 

8.6.4.1. Display List 

In some cases the control line view may have many different 
control lines.  A Right Click over an empty blank space in the 
control line view will get you a short-cut menu with the 
Superelevation Display List dialog.  From this dialog all the control 
lines are listed in the example design we have two.  By selecting 
and deselecting the superelevation in the list then clicking the 
apply button we can turn off the display in super control line 
window view.  This will become very useful when you get into more 
advanced super definitions including rollover locks.  Note that from this dialog we can delete the 
superelevation control lines simply select one and click the Delete button. 
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8.6.4.2. Control Curve Set Station Edit 

The same short-cut menu that had the 
Display List command has an Edit Curve 
Set Stations command.  This will bring 
up a dialog that will list controls for the 
superelevation.  From this dialog we will 
edit Curve Set 1 Full Super start and 
stop stations.   

a) In the Superelevation Control Curve Set Station Edit dialog make curve set 1 active, this 
is indicated by the number shown directly below the Section Name. 

b) Change the Station value for the first Full Super in the list from STA 501+50 to STA 
501+39 > Click the Apply button.  Notice the control line display immediately reflects the 
update. 
 
We changed the first one in the list because it controls the super rate value.  The second 
Full Super in the list is simply constrained vertically to the first.  Now that this is defined 
in a tolerable location we can delete the additional full super points for this curve.  In this 
curve design we will always be in transition, first runoff entering then runoff exiting the 
curve.  We theoretically only have Full Super at one location i.e. STA 501+39. 

c) Close the Superelevation Control Curve Set Station Edit dialog. 

d) If you need to know a points name you can hover 
over the point and the data will display. 

e) Right Click over the L_LANE Full Super Point at 
STA 501+28 > Click the Delete point command 

f) Right Click over the R_LANE Full Super Point at 
STA 501+28 > Click the Delete point command  
 
The Red control line is the Left side 
superelevation control.  The Yellow control line is 
the Right side superelevation control. 
 
Once these points are deleted use the Edit Curve 
Set Stationing short-cut command to review this 
curves banking data.  
 
Notice now there is only one Full Super 
defined for curve 1.  This can also be 
observed directly from the banking 
diagram. 

Note:  An alternative and perhaps more acceptable solution would be to alter the Full Super 
section station values to eliminate the cross over then reduce the Cross slope value.  Each 
design will require judgments, often to find the best solution you will need to test and evaluate 
multiple situations. 
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8.6.4.3. Full Super to Full Super Planar Transition 

There is an option to create full super to full super planar transitions in the Fix Superelevation 
Overlap dialog it would have worked perfectly in this example.  However we can directly edit the 
superelevation control points to create this transition.  Overlapping curve transitions is common.  
The process for creating Full Super to Full Super is quite simple.  If curves have extreme 
overlaps the Fix Superelevation Overlap dialog will not 
delete points that extend into full super sections. 

The image shown here represents super control lines 
that overlap.  The left lane or red line returns to 
normal crown well into the entrance transition of 
reverse curves 1 & 2.  This same overlap condition is 
present between curves 2 & 3.  We will delete all 
control points that reside between the last full super of 
curve 1 and the first full super of curve 2.  Then repeat the process between curves 2 & 3. 

a) From the Display Superelevation mode of the Roadway Designer dialog zoom into the 
overlap area as shown in the image above 

b) Holding your mouse cursor over a blank or black area in this view > Right Click > Select 
Delete Points 

c) To Delete Multiple Points > use your mouse cursor > Click and Hold down > drag your 
mouse creating a fence around all points in the transition overlap area.  When you 
RELEASE the mouse button points inside the window will be deleted. 
 
Note: There is an Undo available [Ctrl + z] or use the undo button on the bottom of the 
super control line view window. 

d) Zoom into the transition overlap area between curves 2 & 3 

e) Repeat the process described above for deleting multiple points. 

 

The resulting banking diagram at this point is shown here.  At the POB of this design we are 
basically in a reverse/normal crown situation that transitions to full super (e=8%) at STA 
501+39; then reverse curve transition from full super to full super (e=6%) at STA 503+90: then 
remain full super to STA 509+06; then reverse curve transition from full super to full super 
(e=8%) STA 512+05; then remain full super to STA 513+84; then transition runoff to normal 
crown at STA 516+34 to POE. 

File > Save your Roadway designer file. 
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8.6.5. Apply Shoulder Rollover Lock 

To this point we have altered the transverse slope of the roadway from the center point (CRWN) 
of the road to the Left and Right Lane points using super elevation controls.  Shoulder 
transverse slopes have remained at slopes as defined in the template.  This may result in a 
sharp change in slope, especially where a full super of +8% changes to a shoulder with a 
transverse slope of -6% resulting in an algebraic difference of 14%.   

Shoulder Rollover Locks are used to limit the algebraic difference that can occur between 
transverse slopes.  As a rule VAOT limits the rollover algebraic difference to 7% on the high 
side of a curve and 0% on the low side of a curve.  In our example project we will define rollover 
locks to be applied to pavement sections between the L_LANE – L_SHLD and the R_LANE – 
R_SHLD points.  

a) From the roadway modeler menu > Superelevation > Apply Shoulder Rollover Locks… 

b) From the Apply Shoulder Rollover Lock dialog> Set Shoulder Point: =  L_SHLD 

c) The Control Line Name: = L_SHLD 

d) High Side Difference = 7.00% 

e) Low Side Difference = 0.00% 

f) Both Maximums are OFF and Station Limits OFF 

g) Click > Apply 

h) Set Shoulder Point: = R_SHLD 

i) The Control line Name: = R_SHLD 

j) High Side Difference = 7.00% 

k) Low Side Difference = 0.00% 

l) Maximums are OFF and Station Limits OFF 

m) Click > Apply > Close 

Using the Superelevation Display 
mode of the Roadway Modeler we 
can view cross sections along the 
corridor to verify the transverse 
slope is working according to our 
intended design.  The image right 
shows super at a rate of -7.80% for 
the traveled way lanes.  The right 
shoulder has a slope of -7.80% 
resulting in a 0.00% algebraic 
difference as we intended.  The Left 
shoulder has a slope of -0.80% the 
resulting algebraic difference here is 7.00% as intended. 

Note: In this example we still have curbing everywhere.  Curbing will not run the entire length of 
this design when completed.  Curbing on this project can be removed where needed when 
parametric constraints and display rules are defined.  
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8.6.5.1. Modify Rollover Locks 

Rollover Lock super control lines can be modified when required.  Bridges often have a 0.00% 
break from lane to shoulder.  In this example we will modify the rollover lock to be 0.00% on the 
high and low sides for the bridge and its approaches.  The approaches start and end 30 feet 
before and after the bridge in this example.  We will modify the rollover locks to transition from 
the standard 7% high 0% low break over  20 feet to the required 0% high and low.   

From the template drops defined in the example project the bridge starts at STA 506+35 and 
ends at STA 507+40.  This means the transition starts at STA 505+85 then reaches the 0% 
rollover lock at STA 506+15 holds this to STA 507+70 then transitions back to the standard at 
STA 507+90. 

a) From the Superelevation Display mode of the 
Roadway Modeler zoom in on curve 2 in the 
control line window 

b) The yellow line represents the R_LANE super 
control; the cyan line represents the R_SHLD 
control line.  When you hover over lines data 
pop-ups indicate the control line name. 

c) Right Click over the cyan line > Select Insert Point 

d) In the Dynamic Settings dialog we will type in the station and slope value we are setting 
for the rollover lock.  This is not the algebraic difference but rather the actual slope the 
shoulders will be set at.  Type the following list in the x+xx,x%= field as shown here: 
[tab] means click the tab key on your keyboard. 

o 50585,-0.01  [tab]  

o 50615,0.06   [tab] 

o 50770,0.06   [tab] 

o 50790,-0.01  [tab] 

e) Right Click in the Super Display window and select Finish.  File > Save > the Roadway 
Modeler File. 

The result will be four points added to the 
R_SHLD control line that will create the 
transition as defined for this example.  The 
image right shows the control line with the four 
points added.  The cross sections should also 
be viewed to insure that the transitions are 
working as designed. 

At this point in the design process you should 
thoroughly review the corridor at all template drops.  Modify and transition all end conditions to 
meet the design criteria.  The modeler cross section view serves as an excellent review of your 
design before any DTM models are created.  There are many additional design capabilities 
available from the InRoads modeler for more on these tools see the InRoads Help. 

We have shown in this example project how to generate a roadway corridor and covered the 
basic tools involved.  The next step in the process is to generate proposed surface models that 
can be used for creating plan set cross sections, proposed contours, quantity information and 
much more. 
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8.7. CREATE PROPOSED SURFACE 

The Roadway Modeler final output is in the form of surface digital terrain model.  The 
combination of Horizontal Geometry, Vertical Geometry, Transverse Geometry, and roadway 
modeler tools create the Surface from defined corridors.  If you have several corridors in your 
modeler they can be combined to create one surface or a new surface for each corridor.  For 
the purpose of this manual we will always create a new surface for each corridor.   

When using the Create Surface tools we will select the appropriate corridor from a list if need 
we can toggle on the Create Alternate Surfaces option.  There are many advanced tools 
available when creating surfaces we will concentrate on fundamental tools. 

Creating a surface from the Roadway Modeler in past versions of InRoads was an iterative 
process.  In the latest versions of InRoads the surface should be relatively complete before you 
need to create a surface.  The DTM created, if the modeler is used to its potential, will require 
much less direct edits than in previous InRoads versions.  That being said most all the standard 
feature edit and design surface tools available previously continue to be available. 

8.7.1. Create Surface 

In the exercise we will create a proposed surface model.  The name of the surface model will by 
default be the same as the name of the corridor.  We will also utilize the alternate surface option 
to create a model for the bottom of pavement.  Finally we will modify the properties of the 
surfaces created and save them to file as well as add them to the project rwk file. 

a) In the Modeler set the Active Surface accordingly, in this example we will set the active 
surface to the original ground i.e. x86e055og 

b) From the Roadway Modeler Select > 
Corridor > Create Surface  

c) From the Create Surface dialog select the 
one corridor you are creating surfaces for 
from the Create Surface(s) from: window.  
For this example we will select the 
RT14prop corridor.  If you have several 
corridors defined they will all be selected 
automatically.  This dialog will run all 
corridors if you let it!  Select only the corridor 
you require. 

d) The default options are shown here.   

e) Toggle ON the Add Transverse Features 
option.  This option will make your surface 
model more accurate and help control the 
triangles at template drops. 

f) Toggle ON the Create Alternate Surface 
Options at the bottom of the dialog. 

g) Click the Apply button…. Wait…. 

h) Close the dialog when the process is 
completed.  Close Roadway Modeler 
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8.7.1.1. Surface Properties 

The surfaces created from the modeler have default properties and should be modified to 
display correctly in plan and cross section.  The alternate surface should also be triangulated 
with minor modifications to reduce extraneous triangles. 

a) From the InRoads explore workspace bar window select the 
surface Tab  

b) Right Click over the proposed surface e.g. RT14prop > Select > 
Properties 

c) On the Main Tab change the Preference field from Default to Surf1.  This will control the 
level that triangles will display on in plan view. 

d) On the Advanced Tab change Cross Section > Symbology to SURFACE_PROPOSED 

e) On the Advanced Tab change Profiles > Symbology to SURFACE_PROPOSED 

f) Click the Apply Button 

g) Right Click and Edit the Properties of the alternate surface e.g. RT14prop-
PAVEBOTTOM 

h) From the Main Tab change the Name: to RT14subbase 
and the Description to Stone Subbase Surface. 

i) Change the Preference to surf5 

j) Change the Maximum Length to 50.00; this will limit triangle legs from being more than 
50 feet in length when the surface is triangulated.  In InRoads 8.9 alternate surfaces do 
get and exterior boundary if add exterior boundary is toggled on when creating surfaces. 

k) On the Advanced Tab set Cross Section and Profile symbology to SURFACE_STONE 
the bottom of pavement is also the top of the subbase compacted stone layer.  These 
setting control the color and level that the surface graphics will be displayed on in their 
respective uses. 

l) Click the Apply Button 

8.7.1.2. Triangulate Proposed Surface 

The alternate surface in this example must be triangulated.  This is the process of applying the 
triangulation algorithm explained in earlier sections of this manual.  When ever changes are 
made to a surface such as features are added or deleted or in our example the maximum length 
is change the surface must be triangulated to include the changes.   

a) From the InRoads main menu Select > Surface > Triangulate Surface 

b) Set the surface to be triangulated active in this dialog e.g. RT14subbase 

c) The Maximum Length can be change in this dialog but in our example it should be 
already set to 50.00 if not set it. 

d) Click the Apply button > Close 
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8.7.1.3. Save Proposed Surfaces 

The two surfaces we created are currently saved in virtual memory only.  These files do not 
exist on any physical memory to this point.  We will save out proposed surfaces to physical 
memory then add these surfaces to our project rwk file.  Project rwk file usage was explained in 
Section 3.7. 

a) From the InRoads explore workspace bar window select the surface Tab  

b) Right Click over the proposed surface e.g. RT14prop > Select > Save As, The surface 
you are saving will be shown as Active: at the bottom of the Save As dialog.  If you use 
the pull down you can select any of the loaded files to save at this point.  Use the pull 
down and select the RT14prop surface.  Notice that the File name: is automatically filled 
in as RT14prop.dtm.  When saving this file to disk it should be saved using the VAOT 
standard file naming convention e.g. z86e055prop.dtm or z86e055vt14prop.dtm to be 
more descriptive. 

c) Change the file name to follow the standard (z86e055vt14prop.dtm) > Click Save. 

d) From the Active Pull down select the VT14subbase surface 

e) Change the file name to follow the standard e.g. z86e055vt14subb.dtm > Click Save. 

f) Cancel the Save As dialog. 

8.7.1.4. Project File Update 

We now have two more files to add to our project file.  It is important to keep the project file up-
to-date.  This file, not only saves you time when loading the project it allows others in the design 
team to load the files included in the Design.  A large portion of good InRoads design practices 
is associated with file management.  As we have see there are lots of different types of files 
associated with the InRoads design, the project file will help track design data. 

a) From the InRoads main menu Select > File > Save AS 

b) From the Save As dialog set the save as type to Project (*.rwk) 

c) Browse to your current project file and select it. 

d) At the bottom of the Save As dialog Select > Options button 

e) From the Project Options dialog select the Surfaces Tab 

f) Toggle on the Update and Add option for the new surfaces e.g. 
VT14prop and VT14subbase, as shown here. 

g) Click > OK > Save > Yes you do want to replace your existing project file with this new 
and revised one. > Cancel the Save As dialog when done. 
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SECTION 9 – CROSS SECTION EVALUATION 

 
9. INTRODUCTION 

Cross Sections are used to display and annotate surfaces and features in a vertical plane.  
Normal Cross Sections are cut at a specified interval perpendicular to the mainline geometry.  
Custom Cross Sections can be defined at any skew angle where needed.  Cross Sections are 
an integral part of design plans.  When InRoads is used to its potential, many of the tedious 
processes involved in drawing Cross Sections can be automated.   

Typically VAOT generates cross sections at 25 or 50 foot intervals, depending on the project.  
VAOT standard cross section sets are drawn with a vertical exaggeration factor of one. The 
amount of annotation that is shown on each cross section can vary depending on the type of 
project.  In this Section of the manual we will generate a standard set of cross sections along 
the example project mainline horizontal alignment i.e. RT14prop.  These cross sections will 
show the existing ground surface model as well as the proposed surface model.  We will 
generate the typical annotations that all VAOT cross sections include, and some that are used 
to aid in the design process. 

 

The typical cross section shown above is cut perpendicular to the mainline horizontal alignment 
RT14prop at station 506+00.  The original ground surface is represented with a line of weight 0 
(dashed).  The proposed surface is represented with a line of weight 1 (solid).  InRoads 8.7 and 
above has the ability to draw components as show here for the proposed pavement and curb.  
Standard final cross section are annotated with the Finish Grade e.g. F.G. = 524.96, and the 
transverse slopes of the proposed surface.  The Cross Section grid and axis annotations can be 
used to measure elevation and offsets for this cross section.  As shown here offset and 
elevation as well as other (not shown) annotations can be made. 

9.1. CREATE CROSS SECTION SET 

Before creating cross section you should load/open all the data files.  For this example we need 
the geometry project loaded.  We are using the horizontal alignment VT14prop as the source for 
creating the cross sections.  Also load/open the surface models that will be shown in the cross 
sections for this example load the original ground surface and the proposed surface model.  The 
proposed surface model we are using is the one created from the Modeler > Roadway Designer 
>in Section 8.7.1 Create Surface.   

Note: Cross Sections that are used as part of the design plan set must but drawn and annotated 
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in the proper drawing file e.g. z86e055xs1.dgn.  The “xs1.dgn” file is the VAOT standard file 
name that indicates cross section data content.   

9.1.1. Steps to Create Cross Section 

a) Set the active horizontal alignment to the one you are creating cross sections for e.g. 
VT14prop. 

b) From the InRoads main menu Select > Evaluation > Cross Section > Create Cross 
Section… 

c) Select - Create Cross 
Section - General Leaf 
(Double click on items in the 
left window to expand and 
activate dialog leafs) 

d) Set Name: by default will be 
the same as your active 
alignment  

e) Create: Window and Data is 
the standard setting. 

f) Interval: The default setting is 50, in our example we will change this to a 25 foot interval. 

g) Left/Right Offset:  70’ left and 70’ right will work in this example, each project may 
require adjustments to this offset depending on the width of the design. 

h) As noted earlier the typical vertical exaggeration for VAOT cross sections is 1. 

i) Toggle on by clicking to X the Surfaces in the surface list window e.g. x86e055og and 
RT14prop are ON and will be drawn in the cross section set. 

Note: When creating cross sections the main goal is to setup the cross sections with proper 
intervals and left/right offsets as well as all other layout and spacing settings.  Once the cross 
section set is generated these type settings cannot be changed; if this requires change the 
entire set must be regenerated.  Surface data including features and components as well as 
the surface lines can be updated or added into cross section sets after the set is created. 

j) Click on the Source leaf and 
make sure that Alignment is 
the selected source and that 
the proper horizontal alignment is shown as active in this dialog.  

k) Click on the Include leaf and toggle on the Surface > Components option to include 
surface components in the cross 
section set. 

l) Click back to the General leaf 

m) At the bottom of the dialog select the 
Preferences button.  There are 2 
named preferences “10_Scale” and “Final x-sec”, the preference “Default” is exactly the 
same as the “10_Scale”.  The “Final x-sec” has a cross grid and additional window 
clearance of 10 feet above and below the surfaces models displayed in the cross section 
window.  If you choose to use the preferences they should be loaded before making 
modifications such as interval of 25’ on the General Leaf because they will be reset 
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when you load a named preference.  Use the Close button to close the dialog without 
loading a preference.    

n) Click the Apply button > you are now prompted by MicroStation to identify a location in 
your drawing window.  Data point to select the bottom left corner of your cross section 
set location.  Cross Sections and Profiles are always placed straight in the X,Y plane of 
the drawing, never rotated. 

o) !!Now REPEAT steps (a) through (n) after loading the named preference “Final x-sec” 
as explained in steps (m). 

Note: use Evaluation > Cross Section > Cross Section Viewer dialog to quickly and efficiently 
browse through large cross section sets one cross section at a time. 

9.2. UPDATE CROSS SECTION SET 

The Update Cross Section dialog is used not only to update surfaces within a cross section but 
to add, remove, or refresh surfaces, Components, Crossing features, Projected Features, and 
Storm and Sanitary Structures.  This function only works on Cross Section Sets that retain their 
cross section set association.  To use the update cross section set commands the geometry 
used to create the cross sections (not a copy of the geometry) and the data to be updated must 
be loaded into the InRoads session.  There are internals ID’s on geometry data, InRoads copies 
of geometry are not considered to be same data i.e. they receive new ID’s.  Files outside of 
InRoads can be copied and ID’s will remain intact i.e. file save as or copy past to create a copy 
of the file.  This being said, care must be taken to keep the original geometry that was used to 
create the cross section set (if you need to retain association). 

Note:  Moving or copying cross sections around in a drawing, or from one drawing to another is 
not recommended.  This can cause them to drop association.  For this reason we carefully 
organize and label all cross sections and profiles in the proper cross section design file where 
only cross section/profile tasks are done. 

9.2.1. Update Surfaces 

Window in on the cross sections to 
be updated 

a) Select > Evaluation > Cross 
Sections > Update Cross 
Section > Select the Surface 
leaf 

b) Use the target button to the right of the cross section set window to select the set to be 
updated.  A MicroStation highlight box will appear around the active set 

c) To Refresh the surface RT14prop toggle the Refresh mode ON and select the surface in 
the surface name listing, multiple surfaces can be selected and refreshed > Click the 
Apply button 

d) To Display Off both surfaces Toggle on the Display Off mode > Select both x86e055og & 
RT14prop surfaces and > Click the Apply button 

e) Display ON, is the same procedure but Toggle on the Display On mode 

9.2.2. Components Display Off/On 

The proposed surface in this example contains components.  Notice when the Surface > 
Display Off mode is applied to RT14prop the components remained visible only the triangulated 



VAOT InRoads Fundamentals Manual----------------------------------------------------------------------------------------------------------------------2007 

VAOT_IFM Page 76 2/20/2007 

 

surface line disappeared 

The process for updating surface Components is much the same as updating surfaces.  Toggle 
on the mode i.e. Refresh | ON | OFF, the select the surface.  A list of components that are in the 
selected surface will be listed in the components name window.  Right Click > Select All > or 
pick and choose only the components that require an update. 

9.2.3. Crossing Features On  

This is an important update function to get familiar with.  Crossing Features must be displayed 
in cross section to be annotated or used in segment slope annotations.  

Window in on the cross sections to be updated 

a) Select > Evaluation > Cross Section > Update Cross Section > Select the Crossing 
Features; leaf 

b) Toggle the Display On mode > Select the proposed surface e.g. RT14prop 

c) Select all the Features in the Feature Name list window > Right Click > Select All 

d) Click > Apply, features points will display in the cross section set > Close 

 

Shown here is an image of proposed surface components with crossing feature points displayed 
in cross section.  Points must be shown in cross sections for feature and segment annotations 
to use them.  Notice all points are shown some as Dots others as + some (not shown here) 
points display as triangles and some will display as detailed cells. 

9.3. ANNOTATE CROSS SECTION SET 

This tool offers the ability to annotate surfaces within a cross section set.  Surface annotations 
typically include transverse slopes (Slope), Finish Grade Elevations (F.G. Elevation), Point 
Offset & elevation (Offset/Elevation), and feature names (Feature w/Leader) or (Feature 
(Pipes)).  On this dialog there are preferences for each of these typical annotations preference 
name are shown in parenthesis.  The (Default) preference is the same as the (F.G. Elevation).  

Note: When annotating cross section toggle the pencil lock to pen lock, this will allow multiple 
annotations without erasing the previous annotation. 

9.3.1. Annotate Cross Sections (Finish Grade) 

a) Make sure all appropriate levels are on in the design file 

b) On the Lock Tool bar change the Pencil lock to Pen lock. 

c) Select > Evaluation > Cross Section > Annotate Cross Section… 

d) One design file can contain several cross sections sets.  At the top of the Annotate 
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Cross Section dialog is a pull down list of sets in the design file that are able to be 
annotated.  Use the target button to tag the cross section set on the screen or select if 
from the list.  When the cross section set is active a MicroStation box should highlight 
around the set. 

e) Select the named Preference F.G. Elevation > Load > Close (from the preference button 
at the bottom of the dialog) 

f) On the Annotate Cross Section General 
leaf toggle on the proposed surface that 
is considered Finish Grade.  The Click 
Apply. 

g) Annotate Cross Sections (Slopes) 

h) Select the named Preference Slope > Load > Close 

i) In the General leaf toggle on the proposed surface e.g. RT14prop 

j) In the Segments Leaf > Annotate > Select all the Crossing Features that require slope 
annotation between them.  This will vary from design to design.  For this example we will 
annotate the roadway traveled way slopes.  Use the CTRL key to select the required 
features. 

j) In the Segments Leaf > Annotate > Select all the 
Crossing Features that require slope annotation 
between them.  This will vary from design to 
design.  For this example we will annotate the 
roadway traveled way slopes.  Use the CTRL key 
to select the required features. 

                         CRWN 
L_LANE 
L_SHLD 

R_LAN 
R_SHLD 

  

k) With Pen Lock ON > Click the Apply button, now segment slopes between these 
features have been annotated. (Right Click > Select None to clear the selection) 

Note: We do not annotate slope for curb or curb buffers because this value is set by the typical 
section details and should not vary along the roadway design. 

l) We will now annotate the slope for end conditions.  This process is done in two steps 
Left side then the Right side because we are annotating all slopes between selected 
features and we do not want a slope annotated between L_EDGE_BUF and 
R_EDGE_BUF.  Use the CTRL key to select the required features 

1st Selection set 2nd Selection set 
L_EDGE_BUF 
L_ROAD_CUT 
L_ROAD_FILL 
L_DITCH 

R_EDGE_BUF  
R_ROAD_CUT 
R_ROAD_FILL 
R_DITCH 

  

With Pen Lock ON > Click the Apply button after each selection set; now end conditions are 
annotated.  Notice slopes greater then 10% are annotated via a slope ratio (Rise:Run). (Right 
Click > Select None) 



VAOT InRoads Fundamentals Manual----------------------------------------------------------------------------------------------------------------------2007 

VAOT_IFM Page 78 2/20/2007 

 

9.3.2. Annotate Cross Sections (Offset/Elevation) 

a) Select the named Preference Offset/Elevation > Load > Close 

b) On the General leaf toggle on the proposed surface e.g. RT14prop 

c) On the Features > Annotate leaf select the features to annotate the offset and elevation 
for.  Use the CTRL key to select the required features 

  
L_ROAD_CUT 
L_ROAD_FILL 
L_DITCH 

R_ROAD_CUT 
R_ROAD_FILL 
R_DITCH 

  

d) With Pen Lock ON > Click the Apply button, now cross sections with cut/fill intercepts will 
get elevation and offset labels on the intercepts.  Cross sections with a Ditch will also be 
labels; this will work for any crossing feature that is displayed in the cross section set. 
(Right Click> Select None) 

e) !!! Toggle the write lock back to Pencil (Standard Setting should be Pencil) 

Note:  Any annotation or point displays can be made larger or smaller using the global scale 
factor add-in or the Tools > Options > Factors Tab, and entering in the desired scale factor. 

This concludes SECTION 9 – CROSS SECTION EVALUATION.  The work flow in this section 
provides a cross section set on the example project with cross sections at the specified 25 foot 
interval.  The annotations in the example set should be as shown on the STA 506+00 cross 
section, at the beginning of this Section.  Cross sections are a fundamental part of the design 
plan set.  Cross section surface data and annotations are only as good as the surface models 
used to generate them.   Previous versions of InRoads contained Edit Feature in Cross Section 
tools these tools are no longer available.  Edits to the surface should ideally be made in the 
Roadway Designer then regenerate the surface, but there are many tools other than the 
Roadway Designer to edit and design surfaces. 

From InRoads Cross Section Sets there are tools available for generating reports such as 
feature offset and slope staking reports or average end area volumes reports/annotations.  
While cross sections provide practical means for construction staking and quantity takeoffs the 
actual surface models (DTM) when well formed and accurately generated can also provide 
construction staking and quantities directly and more accurately.  The use of DTM or other file 
formats that can be generated from DTM’s is actively being sought after by the construction 
industry to use for construction layout and staking.   
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